Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 1442860

Summary: [3.5] Router hangs on deadlock
Product: OpenShift Container Platform Reporter: Ben Bennett <bbennett>
Component: NetworkingAssignee: Ben Bennett <bbennett>
Networking sub component: router QA Contact: zhaozhanqi <zzhao>
Status: CLOSED ERRATA Docs Contact:
Severity: urgent    
Priority: unspecified CC: aos-bugs, bvincell, clichybi, cryan, eparis, erich, jeder, mrobson, nnosenzo, pcameron, pdwyer, rhowe, sreber, stwalter, tdawson, tkimura, vwalek, xtian, zzhao
Version: 3.4.0Keywords: OpsBlocker
Target Milestone: ---   
Target Release: 3.5.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1440977 Environment:
Last Closed: 2017-04-26 05:38:01 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 1440977    
Bug Blocks: 1442859, 1442863    

Comment 1 Eric Paris 2017-04-18 01:41:45 UTC
https://github.com/openshift/ose/pull/707

Comment 2 Troy Dawson 2017-04-18 19:38:23 UTC
This has been merged into ocp and is in OCP v3.5.5.7 or newer.

Comment 4 zhaozhanqi 2017-04-20 10:09:32 UTC
verified this bug on OCP v3.5.5.7

steps:


echo "begin test" > fail1.route;
oc create -f https://raw.githubusercontent.com/openshift-qe/v3-testfiles/master/routing/edge/route_edge.json;

while true;
  do
  oc patch route secured-edge-route -p '{"spec":{"path":"/test"}}';
  oc patch route secured-edge-route -p '{"spec":{"path":"/hello"}}';

done

When running this on OCP v3.5.5.7 about 3 hours, No errors found..

When I running this on old env. found error logs in router pod:
E0420 09:53:13.419135       1 ratelimiter.go:52] error reloading router: exit status 1
[ALERT] 109/095313 (36177) : parsing [/var/lib/haproxy/conf/haproxy.config:118] : 'bind 127.0.0.1:10444' : 'crt-list' : error processing line 1 in file '/var/lib/haproxy/conf/cert_config.map' : unable to load SSL private key from PEM file '/var/lib/haproxy/router/certs/z1:secured-edge-route.pem'.
[ALERT] 109/095313 (36177) : Error(s) found in configuration file : /var/lib/haproxy/conf/haproxy.config

@Ben Bennett 
 Could you help check if this is the correct steps to verify this bug?

Comment 5 Ben Bennett 2017-04-21 13:52:39 UTC
That is a reasonable test.  But Phil Cameron had something that would lock it up far sooner, Phil can you tell us what you were doing that hit this bug?

Comment 6 Phil Cameron 2017-04-24 16:57:24 UTC
I just ran Webin's test. It creates and deletes routes in a tight loop. I run several concurrent scripts.

Comment 8 errata-xmlrpc 2017-04-26 05:38:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1129