Bug 144289 - Widescreen Display Resolution Not Working 1280x720@60
Widescreen Display Resolution Not Working 1280x720@60
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks: FC5Target
  Show dependency treegraph
 
Reported: 2005-01-05 12:04 EST by Evan Patey
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-18 20:59:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log file showing resolution details (45.88 KB, text/plain)
2005-01-06 10:44 EST, Evan Patey
no flags Details
XF86Config (19.67 KB, text/plain)
2005-01-22 21:58 EST, Evan Patey
no flags Details

  None (edit)
Description Evan Patey 2005-01-05 12:04:18 EST
Description of problem:

The default resolution modes are not in widescreen for a 16:9 HDTV
monitor using VGA connection.

xrandr

[root@localhost ~]# xrandr
 SZ:    Pixels          Physical       Refresh
*0   1024 x 768    (  40mm x  30mm )  *75   70   60
 1    800 x 600    (  40mm x  30mm )   75   72   60   56
 2    640 x 480    (  40mm x  30mm )   75
 3    400 x 300    (  40mm x  30mm )   75   72   60
Current rotation - normal
Current reflection - none
Rotations possible - normal
Reflections possible - none

Note:  there should be a widescreen mode of 1280x720

Here is relevant sections from xorg.conf:

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Syntax"
	ModelName    "Olevia LT27HV"
	#HorizSync    31.5 - 48.5
	#VertRefresh  40.0 - 70.0
	Modeline "1280x720@60" 74.25 1280 1336 1472 1600 720 721 724 746
-Hsync +Vsync
EndSection
Section "Device"
	Identifier  "Videocard0"
	Driver      "radeon"
	VendorName  "ATI Technologies"
	BoardName   "ATI Radeon 9800 Pro"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	Monitor    "Monitor0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     16
		Modes    "1280x720" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     24
		Modes    "1280x720" "1024x768" "800x600" "640x480"
	EndSubSection
EndSection





Version-Release number of selected component (if applicable):

Fedora Core 3 Linux version 2.6.9-1.724_FC3 


How reproducible:

startX

Steps to Reproduce:
1.startX
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Sitsofe Wheeler 2005-01-05 12:22:28 EST
Sounds related to bug #130604 . Presumably 1280x720 isn't displayed to you by
system-config-display and thus you were unable to select it as the deafult at
install time?
Comment 2 Evan Patey 2005-01-05 22:27:42 EST
yes this is correct.  however, the manual modeline should preclude
this condition.
Comment 3 Sitsofe Wheeler 2005-01-06 10:28:46 EST
Ah I think I see what you are saying now:
Actual results:
Even with custom xorg.conf (with custom modeline) 1280x720 is not available.

Expected results:
With custom xorg.conf 1280x720 to be available.

Anyway I'd recommend attaching your /var/log/Xorg.0.log because that shows why various choices are refused.
Comment 4 Evan Patey 2005-01-06 10:44:49 EST
Created attachment 109425 [details]
Xorg log file showing resolution details

Please read the sections that show the widescreen resolution failing and advise
on any changes to xorg.conf.
Comment 5 Sitsofe Wheeler 2005-01-06 11:12:21 EST
NOTE: I'm not a xorg expert.

Xorg said it couldn't do 1280x720 because the hsync was out of range for your monitor. Why this is so I don't know - maybe your modeline was wrong. You may get a better answer than any I can give by asking on the fedora-list mailing list (http://www.redhat.com/mailman/listinfo/fedora-list ).
Comment 6 Evan Patey 2005-01-06 19:03:33 EST
How do I get the HSynch in range?  Which number(s) in the modeline do
I need to change?  Please advise.  Also... there is still a defect in
the way the modes are not reported in the GUI.
Comment 7 Evan Patey 2005-01-22 21:55:39 EST
I finally have widscreen resolution.  Here's what I did:

1.  Downloaded AMD64 driver from ATI (brand new release)
2.  Installed driver.  Config'd driver
3.  Switch to DVI output on my vid card
4.  Modified XF86Config.  The file is attached.  

Please notify redhat engineers.
Comment 8 Evan Patey 2005-01-22 21:58:09 EST
Created attachment 110098 [details]
XF86Config

It was a pain, but I got it working using this file on my Syntax Olevia.
Comment 9 Mike A. Harris 2005-02-07 22:27:31 EST
*** This is an automated comment update ***

The X11 implementation included with Fedora Core 2 and 3, is "X.Org X11"
provided by the X.Org project located at "http://www.x.org".  XFree86 is no
longer included in Fedora Core.  To ensure faster review and investigation
of X related Fedora Core bug reports, please be sure to file the bug against
the correct component of "xorg-x11" in the future.  Thanks in advance.

Reassigning several bugs from XFree86 component to proper xorg-x11
component ...
Comment 10 Mike A. Harris 2005-02-11 16:35:07 EST
The X server does not have modelines for widescreen resolutions
built in, so you currently have to hand add custom modelines
to the config file if you have a display with a native resolution
that the X server does not have built in defaults for.

Just to be clear, this is not a video driver or X server bug, and
you do not need to use the unsupported ATI proprietary video
driver.  You can use the "gtf" utility to generate a modeline
for your display, and then paste it into the appropriate part
of the xorg.conf config file.

It is recommended that once you've generated a working modeline
with the "gtf" utility, or set of modelines in different refresh
rates, this should be submitted to X.Org as a request for
enhancement, in the X.Org bugzilla located at:

    http://bugs.freedesktop.org in the "xorg" component.

Once you've filed your RFE in X.Org bugzilla, please paste
the URL here, and we will track the issue, and consider
adding the changes to future updates.

Thanks in advance.
Comment 11 Mike A. Harris 2005-02-11 16:35:42 EST
Setting status to NEEDINFO, awaiting upstream bug URL for tracking.
Comment 12 Mike A. Harris 2005-04-15 10:52:15 EDT
Please file a bug report upstream to X.Org as requested above and paste
the URL here if you prefer Red Hat to track this issue.

Thanks in advance.
Comment 13 Mike A. Harris 2005-04-20 12:39:40 EDT
# 1280x720 @ 60.00 Hz (GTF) hsync: 44.76 kHz; pclk: 74.48 MHz
Modeline "1280x720_60.00"  74.48  1280 1336 1472 1664  720 721 724 746  -HSync
+Vsync

This is a GTF mode.  If you could test that and provide feedback, that
would be appreciated.  We can add it to the extramodes if it works.
Comment 14 Mike A. Harris 2005-05-18 20:59:41 EDT
In comment #13 above, I provided a modeline generated with the "gtf"
utility that comes with Xorg.  The timing differs slightly from the
modeline provided in the initial report, however modelines calculated
using the VESA GTF standard are always prefered over modelines generated
by alternative means.

Before we consider modifying the X server to include this modeline, we
need it to be tested.  If someone is still interested in seeing these
changes added to the distribution, please remove manually supplied modelines
from the X config file, and replace it with the following:

Modeline "1280x720"  74.48  1280 1336 1472 1664  720 721 724 746  -HSync
+Vsync

Add "1280x720" to the "Modes" list in the screen section, and test it.
Provide feedback as to wether it works or not, and either way - attach
your X server log file and config file to the report as individual
uncompressed file attachments for review, then set the bug status back
to "REOPENED".

Due to lack of response in over 3 weeks however, I'm setting the status
to "WONTFIX", as we require the above tests to be performed first, and
have direct feedback from someone who has tested them before we will
consider adding them to the OS by default.  Once the tests are performed,
and status updated, feel free to "REOPEN" if you still want us to track
the problem.

Thanks in advance.

Note You need to log in before you can comment on or make changes to this bug.