Bug 144292 - (VIAsnd82xx) VIA M/B sound chip 8235 not working in KDE desktop
VIA M/B sound chip 8235 not working in KDE desktop
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: redhat-config-soundcard (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bastien Nocera
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-05 13:03 EST by Arthur Baldwin
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-07 10:17:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arthur Baldwin 2005-01-05 13:03:40 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:

The sound works in the default desktop (Gnome) but not in KDE.  I'm
using Apt to update FC3 from ayo.freshrpms.net repository only.
Steps to Reproduce:
1. Install current release of FC3 from DVD
2. run as root and switch desktop to KDE
3. switch MTA to Postfix
4. install Apt from freshrpms.net with default sources.list
5. perform two commands with Apt (apt-get update and apt-get dist-upgrade)
6. use SoundCard Detection item on menu system
7. Properly detects hardware as "Via 82xx"
8. Does not successfully play a sound.

  
Actual results:


Expected results:


Additional info:
Comment 1 Arthur Baldwin 2005-01-07 00:56:07 EST
Got a book, "FC3 Unleashed" and discovered that ALSA is the default
sound system, so I tried setting the levels and saving them with
"alsamixer" and "alsactl store 0" but with no improvement.
Comment 2 Arthur Baldwin 2005-01-07 10:17:44 EST
Well, I'm not sure which package update fixed this problem, but when I
used up2date to update FC3, the problem was resolved.  It took me a
while to realize that the problem had been resolved.  Why?  Because
you have to "lie" to "SoundCard Detection" and say that you heard the
sample sound.  Then you have to use "alsamixer" to set the levels. 
During this operation you will notice that more "channels" are now
showing up.  Use the right and left arrow keys to select the desired
channel, up and down arrow keys to set the level, and press ESC when
finished with all settings.  Then issue the command "alsactl store 0"
to store the settings.  You should now be able to hear the system sounds.

Note You need to log in before you can comment on or make changes to this bug.