Bug 1443061 - "nova volume-attach" should not allow attachment of cinder volume of other project to the instance of admin project
Summary: "nova volume-attach" should not allow attachment of cinder volume of other pr...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: Upstream M2
: 13.0 (Queens)
Assignee: Radomir Dopieralski
QA Contact: Beth White
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-18 12:07 UTC by Md Nadeem
Modified: 2019-09-09 14:12 UTC (History)
14 users (show)

Fixed In Version: python-django-horizon-13.0.1-0.20180302203033.96905f8.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:29:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1683770 None None None 2017-04-21 13:26:17 UTC
OpenStack gerrit 143815 None master: MERGED horizon: Display attachment's server_id when name is no longer available (I15831e2377fe504c667babe5ea00ac09808d296f) 2018-03-21 14:06:24 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:31:00 UTC

Description Md Nadeem 2017-04-18 12:07:38 UTC
Description of problem:

The cinder volume created in other project is not visible under admin project. Similarly nova CLI should not allow to attach other project volume to the admin project instance. Horizon is not permit this kind of operation, however nova CLI allow to do so. 

Further at the other project side, the volume status shows 
"Attached to None on /dev/vdX" which is also a confusing status.

However "nova volume-attach" command 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create volume demo-vol1(Tenant).
2. Create VM admin-vm1(Admin).
3. Source admin credential
4. Use nova volume-attch command to attached the admin-vm1 to the demo-vol1.
5. Open horizon -> under Tenant -> volume.
See that the volume display attach to "None".
​

Actual results:


Expected results:

The Operation should not be allowed as demo-vol1 should not be visible under admin project.

Additional info:

Comment 6 Radomir Dopieralski 2017-12-19 11:34:49 UTC
The upstream bug is closed as "won't fix", in addition, the patch https://review.openstack.org/#/c/143815/4 fixes the displaying of "None" in horizon, and instead displays the server id in such a situation.

Comment 9 errata-xmlrpc 2018-06-27 13:29:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.