Bug 1443132 - rgw_file: readdir fails after dirent-change
Summary: rgw_file: readdir fails after dirent-change
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 2.2
Hardware: All
OS: All
unspecified
high
Target Milestone: rc
: 2.3
Assignee: Matt Benjamin (redhat)
QA Contact: Ramakrishnan Periyasamy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-18 14:27 UTC by Matt Benjamin (redhat)
Modified: 2017-07-30 15:40 UTC (History)
9 users (show)

Fixed In Version: RHEL: ceph-10.2.7-7.el7cp, nfs-ganesha-2.4.5-4.el7cp Ubuntu: ceph_10.2.7-8redhat1, nfs-ganesha_2.4.5-4redhat1xenial
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-19 13:32:25 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Ceph Project Bug Tracker 19634 0 None None None 2017-04-18 14:27:16 UTC
Red Hat Product Errata RHBA-2017:1497 0 normal SHIPPED_LIVE Red Hat Ceph Storage 2.3 bug fix and enhancement update 2017-06-19 17:24:11 UTC

Description Matt Benjamin (redhat) 2017-04-18 14:27:16 UTC
Description of problem:
New chunked readdir strategy failed on READDIR operations after the first, when change attribute has been updated.

How reproducible:
100%


Steps to Reproduce:
1. list large dir
2. add new entry (e.g., mkdir in the dir)
3. list again

Actual results:
Directory is empty

Expected results:
Directory contains all original entries plus new entry.

Comment 19 Ramakrishnan Periyasamy 2017-05-08 07:31:31 UTC
Moving this bug to verified state.

Verified steps available in following pastebin link.

http://pastebin.test.redhat.com/481900

Comment 21 errata-xmlrpc 2017-06-19 13:32:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1497


Note You need to log in before you can comment on or make changes to this bug.