Bug 1443150 - rgw_file: size (and (c|m)time?) attribute(s) incorrect after upload
Summary: rgw_file: size (and (c|m)time?) attribute(s) incorrect after upload
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 2.2
Hardware: All
OS: Unspecified
unspecified
medium
Target Milestone: rc
: 2.3
Assignee: Matt Benjamin (redhat)
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-18 15:13 UTC by Matt Benjamin (redhat)
Modified: 2017-07-30 15:45 UTC (History)
9 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-06-19 13:32:30 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1497 normal SHIPPED_LIVE Red Hat Ceph Storage 2.3 bug fix and enhancement update 2017-06-19 17:24:11 UTC
Ceph Project Bug Tracker 19653 None None None 2017-04-18 15:13 UTC

Description Matt Benjamin (redhat) 2017-04-18 15:13:54 UTC
Description of problem:
Uploaded objects may have incorrect ctime, mtime, or size.

How reproducible:
Unknown

Steps to Reproduce:
1. upload a new object
2. from another mount, check size

Actual results:
size matches expected

Expected results:
size 0

Additional info:
This may have been introduced with SETATTR implementation, but has not be externally reported.

Comment 10 errata-xmlrpc 2017-06-19 13:32:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1497


Note You need to log in before you can comment on or make changes to this bug.