Bug 1443159 - the default value for rhsmcertd splay configuration is not recognized by the config module
Summary: the default value for rhsmcertd splay configuration is not recognized by the ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Jiri Hnidek
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-18 15:35 UTC by John Sefler
Modified: 2017-08-01 19:22 UTC (History)
6 users (show)

Fixed In Version: subscription-manager-1.19.16-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 19:22:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github candlepin subscription-manager pull 1636 None closed 1443159: Added default value for splay configuration 2020-08-13 09:09:15 UTC
Red Hat Product Errata RHBA-2017:2083 normal SHIPPED_LIVE python-rhsm and subscription-manager bug fix and enhancement update 2017-08-01 18:14:19 UTC

Description John Sefler 2017-04-18 15:35:19 UTC
Description of problem:
Recently added as part of the solution to RFE Bug 1435013 in commit e9f8421285fc6541166065a8b55ee89b9a425246 is a new rhsm.conf configuration for rhsmcertd.splay.  The "splay" configuration is a boolean value that defaults to 1.  The subscription-manager config module is not recognizing 1 as its default configuration.

Version-Release number of selected component (if applicable):
[root@jsefler-rhel7 ~]# rpm -q subscription-manager
subscription-manager-1.19.8-1.el7.x86_64


How reproducible:


Steps to Reproduce:
[root@jsefler-rhel7 ~]# subscription-manager config --list
[server]
   hostname = [subscription.rhsm.redhat.com]
   insecure = [0]
   no_proxy = []
   port = [443]
   prefix = [/subscription]
   proxy_hostname = []
   proxy_password = []
   proxy_port = []
   proxy_user = []
   server_timeout = [180]
   ssl_verify_depth = [3]

[rhsm]
   baseurl = [https://cdn.redhat.com]
   ca_cert_dir = [/etc/rhsm/ca/]
   consumercertdir = [/etc/pki/consumer]
   entitlementcertdir = [/etc/pki/entitlement]
   full_refresh_on_yum = [0]
   manage_repos = [1]
   pluginconfdir = [/etc/rhsm/pluginconf.d]
   plugindir = [/usr/share/rhsm-plugins]
   productcertdir = [/etc/pki/product]
   repo_ca_cert = /etc/rhsm/ca/redhat-uep.pem
   report_package_profile = [1]

[rhsmcertd]
   autoattachinterval = [1440]
   certcheckinterval = [240]
   splay = 1                   <============= EXPECTED [1] NOT 1

[logging]
   default_log_level = [INFO]

[] - Default value in use



Actual results:
 above

Expected results:
 The default value of 1 for rhsmcertd splay should be encased in brackets

Additional info:
 This issue is more crucial for the upgrade scenario of subscription-manager from the prior released rhel7.3 version subscription-manager-1.17.15-1 to the latest subscription-manager-1.19.8-1 with an rhsm.conf file that has been altered.  In this case you will not see any value for the new splay configuration when you run "subscription-manager config --list", as follows...

[root@jsefler-rhel7 ~]# subscription-manager config --list | grep rhsmcertd -A10
[rhsmcertd]
   autoattachinterval = [1440]
   certcheckinterval = [240]
                                 <============= NO APPARENT DEFAULT FOR splay
[logging]
   default_log_level = [INFO]

[] - Default value in use

Comment 1 John Sefler 2017-04-18 20:30:27 UTC
Here's another check to show that the splay configuration is missing...

[root@jsefler-rhel7 ~]# subscription-manager config --help | grep rhsmcertd
  --rhsmcertd.certcheckinterval=RHSMCERTD.CERTCHECKINTERVAL
                        Section: rhsmcertd, Name: certcheckinterval
  --rhsmcertd.autoattachinterval=RHSMCERTD.AUTOATTACHINTERVAL
                        Section: rhsmcertd, Name: autoattachinterval
[root@jsefler-rhel7 ~]# 


EXPECTED THESE TWO ADDITIONAL LINES...
  --rhsmcertd.splay=RHSMCERTD.SPLAY
                        Section: rhsmcertd, Name: splay

Comment 2 John Sefler 2017-04-18 20:32:15 UTC
Also expecting bash completion to work...

[root@jsefler-rhel7 ~]# subscription-manager config --rhsmcertd.<TAB><TAB>
--rhsmcertd.autoattachinterval  --rhsmcertd.certcheckinterval   


EXPECTED AN ADDITIONAL BASH COMPLETION FOR...
--rhsmcertd.splay

Comment 4 Shwetha Kallesh 2017-05-25 10:54:28 UTC
[root@dhcp71-27 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 2.1.0-1
subscription management rules: 5.23
subscription-manager: 1.19.16-1.el7
python-rhsm: 1.19.7-1.el7


Default value for rhsmcertd splay configuration:

[root@dhcp71-27 ~]# subscription-manager config --list
[server]
   hostname = skallesh-candlepin.usersys.redhat.com
   insecure = [0]
   no_proxy = []
   port = 8443
   prefix = /candlepin
   proxy_hostname = []
   proxy_password = []
   proxy_port = []
   proxy_user = []
   server_timeout = [180]
   ssl_verify_depth = [3]

[rhsm]
   baseurl = [https://cdn.redhat.com]
   ca_cert_dir = [/etc/rhsm/ca/]
   consumercertdir = [/etc/pki/consumer]
   entitlementcertdir = [/etc/pki/entitlement]
   full_refresh_on_yum = [0]
   manage_repos = [1]
   pluginconfdir = [/etc/rhsm/pluginconf.d]
   plugindir = [/usr/share/rhsm-plugins]
   productcertdir = [/etc/pki/product]
   repo_ca_cert = /etc/rhsm/ca/redhat-uep.pem
   report_package_profile = [1]

[rhsmcertd]
   autoattachinterval = [1440]
   certcheckinterval = [240]
   splay = [1]

[logging]
   default_log_level = [INFO]

[] - Default value in use


[root@dhcp71-27 ~]# subscription-manager config --list | grep rhsmcertd -A10
[rhsmcertd]
   autoattachinterval = [1440]
   certcheckinterval = [240]
   splay = [1]

[logging]
   default_log_level = [INFO]

[] - Default value in use


Help for splay:

[root@dhcp71-27 ~]# subscription-manager config --help | grep rhsmcertd
  --rhsmcertd.splay=RHSMCERTD.SPLAY
                        Section: rhsmcertd, Name: splay
  --rhsmcertd.certcheckinterval=RHSMCERTD.CERTCHECKINTERVAL
                        Section: rhsmcertd, Name: certcheckinterval
  --rhsmcertd.autoattachinterval=RHSMCERTD.AUTOATTACHINTERVAL
                        Section: rhsmcertd, Name: 


Bash completion:


[root@dhcp71-27 ~]# subscription-manager config --rhsmcertd.
--rhsmcertd.autoattachinterval  --rhsmcertd.certcheckinterval   --rhsmcertd.splay

Comment 5 errata-xmlrpc 2017-08-01 19:22:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2083


Note You need to log in before you can comment on or make changes to this bug.