Bug 1443169 - Hosted Engine deployment fails during configuring of ovirtmgmt bridge on RHV-H node
Summary: Hosted Engine deployment fails during configuring of ovirtmgmt bridge on RHV-...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: firewalld
Version: 7.3
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Thomas Woerner
QA Contact: qe-baseos-daemons
Jiri Herrmann
URL:
Whiteboard:
Depends On: 1441530
Blocks: Gluster-HC-3 1433896
TreeView+ depends on / blocked
 
Reported: 2017-04-18 16:23 UTC by Jiri Herrmann
Modified: 2017-06-26 12:54 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
Self-hosted engine deployment fails during bridge configuration When setting up the self-hosted engine on a system with a bridged network configuration, the setup currently fails after the restart of the *firewalld* service. To work around this problem, remove all *.bak files from the `/etc/sysconfig/network-scripts/` directory before deploying self-hosted engine.
Clone Of: 1441530
Environment:
Last Closed: 2017-06-23 14:02:33 UTC


Attachments (Terms of Use)
screenshot of failure with .bak files (107.38 KB, image/png)
2017-05-09 09:15 UTC, RamaKasturi
no flags Details

Comment 3 Thomas Woerner 2017-05-02 15:26:30 UTC
This has been fixed in 7.3.z with #1410860, RHBA-2017-0103
It is also fixed in the 7.4 firewalld rebase.

Which firewalld version are you using?

Comment 7 RamaKasturi 2017-05-05 14:09:04 UTC
sure ryan and Michal, will retest with latest RHV-H and update the bug. 

Does this iso http://download-node-02.eng.bos.redhat.com/devel/candidate-trees/RHVH-4.1-20170425.3/compose/RHVH/x86_64/iso/ has the latest firewalld which is firewalld-0.4.3.2-8.1 ?

Comment 8 Ryan Barry 2017-05-05 14:10:41 UTC
It does.

firewalld-0.4.3.2-8.1 was present in both 4.1.1-1 and 4.1.1-2 squashfs images, and that's for 4.1.1-2

Comment 9 RamaKasturi 2017-05-07 17:11:53 UTC
Thanks Ryan. Will test and update the bug.

Comment 10 RamaKasturi 2017-05-09 09:15:10 UTC
Created attachment 1277338 [details]
screenshot of failure with .bak files

Comment 11 Thomas Woerner 2017-05-09 09:32:44 UTC
Do you still get the .bak files with firewalld-0.4.3.2-8.1?

Could it be that the .bak file has been there already?

Comment 12 RamaKasturi 2017-05-09 11:53:29 UTC
This was a fresh installation and i did not have .bak files before that.

Comment 13 Thomas Woerner 2017-05-29 10:04:53 UTC
I am sorry, but .bak is the expected extension for backup files. firewalld has been using .old before, which broke NM and the network service.

Comment 14 Thomas Woerner 2017-05-29 11:13:36 UTC
From /etc/init.d/network:

# find all the interfaces besides loopback.
# ignore aliases, alternative configurations, and editor backup files
interfaces=$(ls ifcfg-* | \
            LC_ALL=C sed -e "$__sed_discard_ignored_files" \
                       -e '/\(ifcfg-lo$\|:\|ifcfg-.*-range\)/d' \
                       -e '{ s/^ifcfg-//g;s/[0-9]/ &/}' | \
            LC_ALL=C sort -k 1,1 -k 2n | \
            LC_ALL=C sed 's/ //')

From /etc/init.d/functions :

# A sed expression to filter out the files that is_ignored_file recognizes
__sed_discard_ignored_files='/\(~\|\.bak\|\.orig\|\.rpmnew\|\.rpmorig\|\.rpmsave\)$/d'

Comment 15 Thomas Woerner 2017-05-29 11:30:57 UTC
oVirt should use a similar filter.

Comment 16 Thomas Woerner 2017-06-23 14:02:33 UTC
I am closing this as NOT A BUG due to comment #14.


Note You need to log in before you can comment on or make changes to this bug.