Bug 1443205 - improve splay messages in rhsmcertd.log
Summary: improve splay messages in rhsmcertd.log
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.4
Hardware: Unspecified
OS: Unspecified
high
low
Target Milestone: rc
: ---
Assignee: Chris Snyder
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-18 18:23 UTC by John Sefler
Modified: 2017-08-01 19:22 UTC (History)
4 users (show)

Fixed In Version: subscription-manager-1.19.9-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 19:22:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github candlepin subscription-manager pull 1595 None None None 2017-04-20 18:55:05 UTC
Red Hat Product Errata RHBA-2017:2083 normal SHIPPED_LIVE python-rhsm and subscription-manager bug fix and enhancement update 2017-08-01 18:14:19 UTC

Description John Sefler 2017-04-18 18:23:52 UTC
Description of problem:
After the introducing the new RFE Bug 1435013 there are now two delay messages logged to the rhsmcertd.log....

Waiting 2.0 minute(s) plus 83068 splay second(s) [83188 seconds(s) totals] before performing first auto-attach.
Waiting 2.0 minute(s) plus 5780 splay second(s) [5900 seconds(s) totals] before performing first cert check.
                  ^^^                       ^^^             ^^^^      ^

Let's simplify the plurals for readability and help the foreign translations to the following...

Waiting 2.0 minutes plus 83068 splay seconds [83188 seconds total] before performing first auto-attach.
Waiting 2.0 minutes plus 5780 splay seconds [5900 seconds total] before performing first cert check.



Version-Release number of selected component (if applicable):
[root@jsefler-rhel7 ~]# rpm -q subscription-manager
subscription-manager-1.19.8-1.el7.x86_64


How reproducible:


Steps to Reproduce:
[root@jsefler-rhel7 ~]# systemctl restart rhsmcertd.service
[root@jsefler-rhel7 ~]# tail -f /var/log/rhsm/rhsmcertd.log
Tue Apr 18 14:17:39 2017 [INFO] Starting rhsmcertd...
Tue Apr 18 14:17:39 2017 [INFO] Auto-attach interval: 4.0 minute(s) [240 second(s)]
Tue Apr 18 14:17:39 2017 [INFO] Cert check interval: 3.0 minute(s) [180 second(s)]
Tue Apr 18 14:17:39 2017 [INFO] Waiting 2.0 minute(s) plus 125 splay second(s) [245 seconds(s) totals] before performing first auto-attach.
Tue Apr 18 14:17:39 2017 [INFO] Waiting 2.0 minute(s) plus 165 splay second(s) [285 seconds(s) totals] before performing first cert check.


Actual results:


Expected results:


Additional info:

Comment 2 John Sefler 2017-04-18 18:51:42 UTC
If we make the changes in comment 0, then let's change these too...

Auto-attach interval: 4.0 minute(s) [240 second(s)]
Cert check interval: 3.0 minute(s) [180 second(s)]
                               ^^^            ^^^
change to...

Auto-attach interval: 4.0 minutes [240 seconds]
Cert check interval: 3.0 minutes [180 seconds]

Comment 3 Chris Snyder 2017-04-20 18:55:06 UTC
Attaching a PR with the requested changes as an external tracker.

Comment 5 Shwetha Kallesh 2017-05-03 06:36:03 UTC
[root@dhcp71-191 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.9.51.21-1
subscription management rules: 5.15.1
subscription-manager: 1.19.12-1.el7
python-rhsm: 1.19.6-1.el7


[root@dhcp71-191 ~]# tail -f /var/log/rhsm/rhsmcertd.log
Wed May  3 02:03:18 2017 [INFO] Auto-attach interval: 1440.0 minutes [86400 seconds]
Wed May  3 02:03:18 2017 [INFO] Cert check interval: 240.0 minutes [14400 seconds]
Wed May  3 02:03:18 2017 [INFO] Waiting 2.0 minutes plus 45627 splay seconds [45747 seconds total] before performing first auto-attach.
Wed May  3 02:03:18 2017 [INFO] Waiting 2.0 minutes plus 9697 splay seconds [9817 seconds total] before performing first cert check.
Wed May  3 02:26:32 2017 [INFO] rhsmcertd is shutting down...
Wed May  3 02:26:32 2017 [INFO] Starting rhsmcertd...
Wed May  3 02:26:32 2017 [INFO] Auto-attach interval: 1440.0 minutes [86400 seconds]
Wed May  3 02:26:32 2017 [INFO] Cert check interval: 240.0 minutes [14400 seconds]
Wed May  3 02:26:32 2017 [INFO] Waiting 2.0 minutes plus 46929 splay seconds [47049 seconds total] before performing first auto-attach.
Wed May  3 02:26:32 2017 [INFO] Waiting 2.0 minutes plus 2864 splay seconds [2984 seconds total] before performing first cert check.

Comment 6 errata-xmlrpc 2017-08-01 19:22:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2083


Note You need to log in before you can comment on or make changes to this bug.