Bug 144322 - fence method configured without device args: ccsd and fence spin, consume %100 CPU
fence method configured without device args: ccsd and fence spin, consume %10...
Status: CLOSED NEXTRELEASE
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: fence (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam "mantis" Manthei
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-05 17:20 EST by Derek Anderson
Modified: 2009-04-16 15:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-01 15:48:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Derek Anderson 2005-01-05 17:20:32 EST
Description of problem:
I wanted to use a simple fence method with no arguments (like
/bin/true).  Part of the cluster.conf file looks like this:

<clusternode name="link-10" votes="1">
  <fence>
    <method name="abc">
      <device name="123"/>
    </method>
  </fence>
</clusternode>

...
<fencedevices>
  <fencedevice name="123" agent="logger DIE, FOO"/>
</fencedevices>

The problem line is:
      <device name="123"/>

It can be unproblemmed by adding something, like:
      <device name="123" myargs="getsome"/>

The problem is that when a fence operation is attempted ccsd and
fence_tool join together to consume 100% CPU and hang:
 2767 root      16   0 14536 1356 1136 S 60.6  0.3   6:53.13 ccsd
 2775 root      25   0  1648  308  252 R 39.3  0.1   4:36.51 fence_tool


Version-Release number of selected component (if applicable):
6.1 RPMS built Wed 15 Dec 2004 01:13:08 PM CST

How reproducible:
Yes.

Steps to Reproduce:
1. Configure a fence device with only a "name" key/value
2. Start fence_tool -D
3. 
  
Actual results:
Hangs on the first attempted fence operation, which is:
"fence_tool: unfence ourself"

Expected results:
Don't do that.


Additional info:
Comment 1 Jonathan Earl Brassow 2005-01-07 15:40:44 EST
note to dct:

ccs_get_list is now available, which will not barf in the presence of
the above situation.
Comment 2 David Teigland 2005-01-09 21:48:36 EST
fenced now uses ccs_get_list to avoid the problem
Comment 3 Derek Anderson 2005-03-01 15:48:09 EST
Verified against 2/28/2005 build.

Note You need to log in before you can comment on or make changes to this bug.