Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.

Bug 1443290

Summary: Failure noticed during IPA upgrade
Product: Red Hat Enterprise Linux 7 Reporter: Nikhil Dehadrai <ndehadra>
Component: ipaAssignee: IPA Maintainers <ipa-maint>
Status: CLOSED DUPLICATE QA Contact: ipa-qe <ipa-qe>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 7.4CC: mbasti, pvoborni, rcritten, tscherf
Target Milestone: rcKeywords: Regression
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-04-20 15:05:28 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Nikhil Dehadrai 2017-04-19 04:35:02 UTC
Description of problem:
Failure noticed during IPA upgrade from RHEL 7.2.z to RHEL 7.4

Version-Release number of selected component (if applicable):
ipa-server-4.5.0-6.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Setup IPA-server at RHEL 7.2.z. (In my case IPA server is setup in Permissive mode)
2. Use the latest repo links for RHEL 7.4
3. Update the ipa server by executing commands:
# yum -y update 'ipa*' sssd

Actual results:
1. After step 3, the yum update process completes, but ipa-server upgrade failed message is noticed at /var/log/ipaupgrade.log.

[root@auto-hv-01-guest04 ~]# tail -20 /var/log/ipaupgrade.log 
2017-04-19T03:01:08Z ERROR IPA server upgrade failed: Inspect /var/log/ipaupgrade.log and run command ipa-server-upgrade manually.
2017-04-19T03:01:08Z DEBUG   File "/usr/lib/python2.7/site-packages/ipapython/admintool.py", line 172, in execute
    return_value = self.run()
  File "/usr/lib/python2.7/site-packages/ipaserver/install/ipa_server_upgrade.py", line 46, in run
    server.upgrade()
  File "/usr/lib/python2.7/site-packages/ipaserver/install/server/upgrade.py", line 1868, in upgrade
    upgrade_configuration()
  File "/usr/lib/python2.7/site-packages/ipaserver/install/server/upgrade.py", line 1700, in upgrade_configuration
    bind.start()
  File "/usr/lib/python2.7/site-packages/ipaserver/install/service.py", line 320, in start
    self.service.start(instance_name, capture_output=capture_output, wait=wait)
  File "/usr/lib/python2.7/site-packages/ipaplatform/base/services.py", line 290, in start
    skip_output=not capture_output)
  File "/usr/lib/python2.7/site-packages/ipapython/ipautil.py", line 495, in run
    raise CalledProcessError(p.returncode, arg_string, str(output))

2017-04-19T03:01:08Z DEBUG The ipa-server-upgrade command failed, exception: CalledProcessError: Command '/bin/systemctl start named-pkcs11.service' returned non-zero exit status 1
2017-04-19T03:01:08Z ERROR Unexpected error - see /var/log/ipaupgrade.log for details:
CalledProcessError: Command '/bin/systemctl start named-pkcs11.service' returned non-zero exit status 1
2017-04-19T03:01:08Z ERROR The ipa-server-upgrade command failed. See /var/log/ipaupgrade.log for more information
[root@auto-hv-01-guest04 ~]# 


Expected results:
IPA upgrade process should complete successfully without any failures.

Additional Info:
Similar issue is observed for upgrade from RHEL 7.1.z to RHEL 7.4

Comment 5 Martin Bašti 2017-04-19 13:20:06 UTC
Hello,

could you please provide journalctl -u named-pkcs11 output?

Thanks

Comment 9 Martin Bašti 2017-04-20 15:05:28 UTC
After a closer investigation, it looks related to bug https://bugzilla.redhat.com/show_bug.cgi?id=1443931

Apr 20 19:59:29 vm-idm-030.testrelm.test systemd[1]: Assertion 'a >= 0 && a < _JOB_TYPE_MAX_MERGING' failed at src/core/job.c:346, function job_type_lookup_merge(). Aborting.

So IMHO these random service failures may be caused by failing systemd

*** This bug has been marked as a duplicate of bug 1443931 ***