Bug 144334 - cannot acces dvd+r mounted as user
cannot acces dvd+r mounted as user
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-05 22:42 EST by Dmitry Savransky
Modified: 2015-01-04 17:14 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 01:24:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitry Savransky 2005-01-05 22:42:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
I just installed a new Memorex dual format dvd+r/rw drive on a
computer which already has a regular dvd drive and a cdwriter (the
drives are cdrom2, cdrom1 and cdrom, respectively).  The new drive
plays regular cds and dvds just fine, but when I attempt to access a
dvd+r (recorded on a windows xp machine) mounted as a user I get:

[ds264@caliban /mnt]$ cd cdrom2
cdrom2: Permission denied.

Also, for some reason, the permissions change to:
dr--r--r--   2 4294967295 4294967295 1792 Dec  9 15:53 cdrom2
as opposed to:
dr-xr-xr-x   1 root root 2048 Dec 31  1969 cdrom2
which i get for any other media type.
Finally, when I mount the disk as root, I am able to access it and
view the files on it but the permissions look the same as when I mount
it as a user.

The relevant part of my fstab looks like this:
/dev/cdrom2  /mnt/cdrom2  udf,iso9660 noauto,owner,kudzu,ro 0 0
I have tried changing it to:
udf,iso9660 user,noauto,owner,kudzu,ro 0 0
and
udf,iso9660 users,unhide,noauto,owner,kudzu,ro 0 0
with no effect.
I have also tried running chmod 777 /dev/hdb (this is the drive in
question), also to no effect.

Version-Release number of selected component (if applicable):
kernel-2.6.9-1.11

How reproducible:
Always

Steps to Reproduce:
1.Place DVD+R into drive
2.mount /mnt/cdrom2
3.cd /mnt/cdrom2
    

Actual Results:  permission denied

Expected Results:  should have been able to access the drive

Additional info:
Comment 1 Dave Jones 2005-04-16 01:24:52 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.
Comment 2 Orion Poplawski 2005-05-25 13:27:52 EDT
I see this in FC3 kernel 2.6.11-1.14_FC3smp.  If mounted udf, I see the above
behavior.  If mounted iso9660 it works.  Disk claims to be in Joliet format
(according to the label on it).
Comment 3 Dmitry Savransky 2005-05-25 13:36:07 EDT
This problem went away after a clean install of Fedora Core 3 for me.
Comment 4 Orion Poplawski 2005-05-25 13:57:51 EDT
Mine is a fresh install as well.  What kernel and what filesystem are your dvd's
being mounted with?  Also, could you list your /etc/fstab entry for the dvd
device?  Thanks!

Note You need to log in before you can comment on or make changes to this bug.