Bug 144337 - system-config-printer doesn't setup sharing with All Hosts correctly
system-config-printer doesn't setup sharing with All Hosts correctly
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
3
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-05 23:52 EST by Chris Bagwell
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-06 18:27:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Bagwell 2005-01-05 23:52:38 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
This could be operator error but...

I've got a private network with 1 server running with multiple
printers connected to it using Fedora Core 3.  I'd like to set the
Share option for "All Hosts" so that all other computers automatically
see (linux anyways) and  print to these IPP printers (from both
windows and linux).

So I use the system-config-printer program, highlight my printer queue
and hit the "Sharing..." button to bring up the sharing properties.

From that window, I check the "This queue is available to other
computers".  By default it says allowed hosts are "All Host".

When I save/apply these changes the updated cupsd.conf file only sets
up sharing for the 127.0.0.1 address.  I would expect a line that
reads "Allow from All".

Example section from written cupsd.conf.

<Location /printers/stylus-photo-r300-1>
Order Deny,Allow
Deny From All
Allow From 127.0.0.1
AuthType None
</Location>

As a work around, I use the GUI to set up sharing from a specific
network address range.  This will create a more usable cupds.conf
file.  Example:

<Location /printers/stylus-photo-r300-1>
Order Deny,Allow
Deny From All
Allow From 127.0.0.1
AuthType None
Allow from 192.168.1.0/255.255.255.0
</Location>

Yeah, I know the later is more secure but its a private network that
I'm constantly messing with IP addresses and Allow from All would be
nice.  :-)

This has been the behavior since at least Fedora Core 1.

Version-Release number of selected component (if applicable):
system-config-printer-0.6.116-1

How reproducible:
Always

Steps to Reproduce:
1.  Create printer queue
2.  Select Sharing from system-config-printer Action menu.
3.  Check allow sharing.
4.  Apply changes and then verify "Allow from All" is not in cupds.conf
    

Additional info:
Comment 1 Tim Waugh 2005-01-06 10:18:26 EST
This works fine here.

Please attach the output of 'printconf-tui --Xexport', making sure to remove any
passwords it may contain.
Comment 2 Chris Bagwell 2005-01-06 12:30:28 EST
Something has changed in my system and now those steps do not
reproduce the problem for me either.  Thank you for your time and
please close this report.

I will continue to try and reproduce the problem over time and then
use the printconf command for future reports.  I suspect that its some
confusion between me hand modifying cupds.conf and then using
system-config-printer to do certain other modifications.

Note You need to log in before you can comment on or make changes to this bug.