Bug 144345 - Browsing for content handlers -gtk2 file open
Browsing for content handlers -gtk2 file open
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-06 05:17 EST by Ivan Gyurdiev
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-06 05:26:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivan Gyurdiev 2005-01-06 05:17:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041228 Firefox/1.0 Fedora/1.0-8

Description of problem:
Browsing for content handlers is absurdly slow with 
the Gtk2 File open dialog. It takes forever (45 secs-1min?) 
to index /usr/bin, which is the target location of basically
all programs you'll be looking for. 

The Gtk2 file open dialog badly needs a bar where
the user can type in the file. I can't understand
why the gtk team would decide to remove it, but
it's a bad idea, and at least firefox should have
such a bar. Please add one, since without it
the BROWSE button when opening content is completely
useless.

The "Change Action" dialog in the preferences
when you click on different extension does what I want.






Version-Release number of selected component (if applicable):
firefox-1.0-8

How reproducible:
Always

Steps to Reproduce:
1. See summary    

Additional info:
Comment 1 Warren Togami 2005-01-06 05:26:28 EST
What you are complaining about is not a firefox problem, but GTK
itself.  It was designed on purpose in that way, probably because
their usability studies thinks that it is "best" that way.  Yes it
makes many people used to other interfaces uncomfortable including me.
 But it is the wrong place to complain here.  You have to make your
case to the upstream GTK and GNOME projects.
Comment 2 Ivan Gyurdiev 2005-01-06 05:47:50 EST
Yes, but there's nothing stopping you from having a bar *and* a 
browse dialog in firefox. In fact, that's what the "Change Action"
dialog already does. If the dialog doesn't provide the functionality
that is needed, it seems that a bar should be added as well.

I'll probably complain on GNOME bugzilla about the treeview performance.
Comment 3 Warren Togami 2005-01-06 05:55:38 EST
AFAIK that is not even an option in the new GTK file chooser.  Or
maybe I just have not seen anybody implement a dialog that way.  In
any case this is a higher level problem than just firefox, so it is
not useful to complain about here.
Comment 4 Ivan Gyurdiev 2005-01-06 06:13:46 EST
Hmm I just realized that the "Change Action" dialog 
doesn't let you type in the bar. So much for using that as 
an example. To the GNOME bugzilla...
Comment 5 Christopher Aillon 2005-01-06 20:52:42 EST
As a note, you can press CTRL+L or '/' to bring up something you can
type into, which includes typeahead.
Comment 6 Warren Togami 2005-01-06 21:14:40 EST
The drawback of that dialog however is you can only navigate to a
path.  It throws away the file at the end of your typed path and you
are still forced to choose a file manually.

Note You need to log in before you can comment on or make changes to this bug.