Bug 144350 - recompile of nss_ldap-227-1 don't working on rhel3
recompile of nss_ldap-227-1 don't working on rhel3
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: nss_ldap (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-06 06:20 EST by Levente Farkas
Modified: 2008-04-07 08:09 EDT (History)
1 user (show)

See Also:
Fixed In Version: 8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-07 08:09:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Levente Farkas 2005-01-06 06:20:50 EST
Description of problem:
after i recompile nss_ldap-227-1 and openldap-2.2.13 on rhel3 it seems
that nss_ldap is no longer working. there are such messages in the
/var/log/slapd.log:
Jan  6 12:13:51 kek slapd[15903]: @(#) $OpenLDAP: slapd 2.2.13 (Oct  6
2004 16:49:22) $        
lfarkas@atom.int.bppiac.hu:/mnt/md2/home/lfarkas/rpm/BUILD/openldap-2.2.13/openldap-2.2.13/build-servers/servers/slapd
Jan  6 12:13:51 kek slapd[15903]: daemon: IPv6 socket() failed
errno=97 (Address family not supported by protocol)
Jan  6 12:13:51 kek slapd[15903]: daemon: IPv6 socket() failed
errno=97 (Address family not supported by protocol)
Jan  6 12:13:51 kek slapd[15903]: nss_ldap: reconnecting to LDAP server...
Jan  6 12:13:51 kek slapd[15903]: nss_ldap: reconnecting to LDAP server...
Jan  6 12:13:51 kek slapd[15903]: nss_ldap: reconnecting to LDAP
server (sleeping 4 seconds)...
Jan  6 12:13:55 kek slapd[15903]: nss_ldap: reconnecting to LDAP
server (sleeping 8 seconds)...
Jan  6 12:14:03 kek slapd[15903]: nss_ldap: reconnecting to LDAP
server (sleeping 16 seconds)...


Version-Release number of selected component (if applicable):
227-1

How reproducible:
always

Steps to Reproduce:
1. upgrade to nss_ldap-227-1
2. restart ldap
3.
  
Actual results:
restart ldap never finish

Expected results:
work like with nss_ldap-226-3, since with 226 everything is working!

Additional info:
Comment 1 Karsten Hopp 2005-10-13 09:13:12 EDT
Why did you file this at a Fedora Core bug ? Does the problem exist on a Rawhide
system, too ? Or is it just that the Fedora Core package doesn't work on RHEL-3 ?
The latter could be expected as thelatest supported nss_ldap on RHEL-3 is
nss_ldap-207-15.
Comment 2 Levente Farkas 2005-10-13 10:25:39 EDT
it's just a typo and i'd like to write fc3:-(
Comment 3 Bug Zapper 2008-04-03 11:48:17 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

Note You need to log in before you can comment on or make changes to this bug.