Bug 1443554 - Subscription Manager GUI can't open Getting started at RHEL 7
Summary: Subscription Manager GUI can't open Getting started at RHEL 7
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.3
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Jiri Hnidek
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-19 12:58 UTC by Jiri Hnidek
Modified: 2017-08-01 19:22 UTC (History)
3 users (show)

Fixed In Version: subscription-manager-1.19.10-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 19:22:43 UTC
Target Upstream Version:


Attachments (Terms of Use)
Getting started opens after installing gui and xauth (257.93 KB, image/png)
2017-05-04 10:59 UTC, Shwetha Kallesh
no flags Details
Getting started opens after installing gui and xauth (104.17 KB, image/png)
2017-05-04 11:11 UTC, Shwetha Kallesh
no flags Details


Links
System ID Priority Status Summary Last Updated
Github candlepin subscription-manager pull 1592 None closed 1443554: Clicking at Help->Getting Started opens yelp. 2020-06-24 11:32:30 UTC
Red Hat Bugzilla 1448383 None CLOSED Memory pressure relief messages on terminal when launched "Help" documents from subscription-manager GUI 2019-04-10 17:56:26 UTC
Red Hat Product Errata RHBA-2017:2083 normal SHIPPED_LIVE python-rhsm and subscription-manager bug fix and enhancement update 2017-08-01 18:14:19 UTC

Internal Links: 1448383

Description Jiri Hnidek 2017-04-19 12:58:59 UTC
Description of problem:
When click at Help->Getting Started item in subscription-manager-gui at RHEL7 or Fedora, then nothing happens, because subscription-manager-gui tries to open ghelp:subscription-manager using gnome-open command and it isn't available at rhel7/fedora anymore. It probably works at RHEL6.

Version-Release number of selected component (if applicable):
[root@localhost ~]# subscription-manager version
server type: This system is currently not registered.
subscription management server: 0.9.51.21-1
subscription management rules: 5.15.1
subscription-manager: 1.17.15-1.el7.centos
python-rhsm: 1.17.9-1.el7

How reproducible:
always

Steps to Reproduce:
1. Launch subscription-manager-gui
2. Click at: Help->Getting Started in main menu

Actual results:
Nothing happens.

Expected results:
Open documentation in yelp app.

Additional info:

Comment 2 Jiri Hnidek 2017-04-19 14:28:41 UTC
I guess it is easy to fix replacing gnome-open with xdg-open. Taking this bug.

Comment 3 Kevin Howell 2017-04-20 15:01:03 UTC
Note: we believe that this only occurs in the use case where a user starts with a minimal installation and does yum install subscription-manager-gui (similar to our font issue). We want to support this by providing proper requirements in the spec file, etc.

The more typical use case is to install @Desktop group, which provides implicitly necessary requirements, thus the lower priority/severity. Nevertheless, this issue is valid and valuable to fix.

Comment 5 Shwetha Kallesh 2017-05-04 10:59:50 UTC
Created attachment 1276244 [details]
Getting started opens after installing gui and xauth

Marking bug as verified 

[root@bkr-hv01-guest04 ~]# subscription-manager version
server type: This system is currently not registered.
subscription management server: 0.9.51.21-1
subscription management rules: 5.15.1
subscription-manager: 1.19.12-1.el7
python-rhsm: 1.19.6-1.el7

Comment 6 Shwetha Kallesh 2017-05-04 11:11:16 UTC
Created attachment 1276259 [details]
Getting started opens after installing gui and xauth

[root@bkr-hv01-guest04 ~]# subscription-manager version
server type: This system is currently not registered.
subscription management server: 0.9.51.21-1
subscription management rules: 5.15.1
subscription-manager: 1.19.12-1.el7
python-rhsm: 1.19.6-1.el7

Comment 7 errata-xmlrpc 2017-08-01 19:22:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2083


Note You need to log in before you can comment on or make changes to this bug.