Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 1443570 - [RFE] Please remove reference to retired article in subscription-manager man page
[RFE] Please remove reference to retired article in subscription-manager man ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.3
Unspecified Linux
low Severity low
: rc
: ---
Assigned To: Jiri Hnidek
John Sefler
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-04-19 09:37 EDT by Rick Dixon
Modified: 2018-04-10 05:49 EDT (History)
5 users (show)

See Also:
Fixed In Version: subscription-manager-1.20.2-1
Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 05:49:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Github candlepin/subscription-manager/pull/1647 None None None 2017-06-02 03:26 EDT
Red Hat Product Errata RHBA-2018:0681 None None None 2018-04-10 05:49 EDT

  None (edit)
Description Rick Dixon 2017-04-19 09:37:15 EDT
The man page for subscription-manager currently references a retired article for disabling location-aware updates:

---
NETWORK INFORMATION
The subscription-manager tool uses outgoing HTTPS requests. In the default configuration  it  will  use  HTTPS  on  port  443  to  the  subscription servers subscription.rhsm.redhat.com and to the content delivery service cdn.redhat.com.

For information about the network addresses that subscription-manager and  the  subscription-manager yum plugin use see https://access.redhat.com/site/articles/414963
---

The article has been retired and contains a private note:

---
KCS solution: https://access.redhat.com/site/solutions/59586

I've retired the article in favor of the solution at this point, because previous the solution linked to the article, which linked to the docs. I've updated the solution to include the link to the docs along with the information found here to eliminate one step for customers.
---

Can we update the man page to link to the KCS rather than the retired article?
Comment 2 Rick Dixon 2017-04-19 09:40:49 EDT
Follow-up:  I should note that customers who follow the current link in the man page land on a page stating "Access Denied" with no redirection. To preserve a positivie customer experience, perhaps a temporary redirect to the KCS article until the man page can be updated would be helpful.
Comment 3 Nikola Forró 2017-04-19 10:06:23 EDT
subscription-manager.8 man page is part of subscription-manager component, not man-pages:

$ rpm -qf $(man -w subscription-manager)
subscription-manager-1.17.15-1.el7.x86_64
Comment 6 Rehana 2017-11-09 07:08:45 EST
Reproducing the failure:
========================
subscription-manager: 1.19.21-1.el7
python-rhsm: 1.19.9-1.el7

[root@dhcp35-85 ~]# man subscription-manager | grep https://access.redhat.com/site/articles/414963 -B5

NETWORK INFORMATION
       The  subscription-manager  tool  uses  outgoing HTTPS requests. In the default configuration it will use HTTPS on port 443 to the subscription servers subscription.rhsm.redhat.com and to the content
       delivery service cdn.redhat.com.

       For information about the network addresses that subscription-manager and the subscription-manager yum plugin use see https://access.redhat.com/site/articles/414963

Retesting on :
==============
subscription management server: 2.0.43-1
subscription management rules: 5.26
subscription-manager: 1.20.5-1.el7

[root@ibm-x3650m4-01-vm-09 ~]# man subscription-manager | grep https://access.redhat.com/site/solutions/59586 -A10 -B5

NETWORK INFORMATION
       The subscription-manager tool uses outgoing HTTPS requests. In the default configuration it will use HTTPS on port 443 to the subscription servers subscription.rhsm.redhat.com  and  to  the  content
       delivery service cdn.redhat.com.

       For information about the network addresses that subscription-manager and the subscription-manager yum plugin use see https://access.redhat.com/site/solutions/59586


Observed that now the article link is updated "https://access.redhat.com/site/solutions/59586" instead of "https://access.redhat.com/site/articles/414963"


Marking as Verified!!
Comment 9 errata-xmlrpc 2018-04-10 05:49:05 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0681

Note You need to log in before you can comment on or make changes to this bug.