Bug 1443645 - User can no longer use API having password with special character "+".
Summary: User can no longer use API having password with special character "+".
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.0.7
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ovirt-4.2.0
: ---
Assignee: Ravi Nori
QA Contact: Lucie Leistnerova
URL:
Whiteboard:
Depends On:
Blocks: 1445944
TreeView+ depends on / blocked
 
Reported: 2017-04-19 15:33 UTC by Ameya Charekar
Modified: 2020-05-14 15:59 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
: 1445944 (view as bug list)
Environment:
Last Closed: 2018-05-15 17:41:54 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1464140 0 high CLOSED RHV: Unexpected comma or semicolon found at the end of the DN string when login with AD account 2021-02-22 00:41:40 UTC
Red Hat Product Errata RHEA-2018:1488 0 None None None 2018-05-15 17:43:01 UTC
oVirt gerrit 75668 0 master MERGED aaa: User can no longer use API having password with special character "+" 2021-02-18 10:29:52 UTC
oVirt gerrit 75694 0 ovirt-engine-4.1 MERGED aaa: User can no longer use API having password with special character "+" 2021-02-18 10:29:52 UTC

Internal Links: 1464140

Description Ameya Charekar 2017-04-19 15:33:27 UTC
Description of problem:
Super user having password with a special character "+" can not use API and it will fail with error:
"HTTP/1.1 401 Unauthorized"


Version-Release number of selected component (if applicable):
rhevm-4.0.7.4-0.1.el7ev.noarch

How reproducible:
Always

Steps to Reproduce:
1. Set password of admin@internal user having special character "+"/
2. Try to connect to API.
3.

Actual results:
401 Unauthorized

Expected results:
Should be able to connect to API.

Additional info:
Works fine in rhev 3.6.

Comment 2 rhev-integ 2017-04-26 10:50:04 UTC
WARN: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason:

[FOUND NON-ACKED FLAGS: {'rhevm-4.1.z': '?'}]

For more info please contact: rhv-devops@redhat.com

Comment 5 Lucie Leistnerova 2017-11-06 10:12:16 UTC
login to API successful with '+' in password

verified in ovirt-engine-4.2.0-0.4.master.el7.noarch

Comment 8 errata-xmlrpc 2018-05-15 17:41:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:1488

Comment 9 Franta Kust 2019-05-16 13:06:44 UTC
BZ<2>Jira Resync


Note You need to log in before you can comment on or make changes to this bug.