Bug 144367 - FC3 Install Kernel Panics on Dell Precision 670n at ata_piix
FC3 Install Kernel Panics on Dell Precision 670n at ata_piix
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-06 10:28 EST by Thomas J. Baker
Modified: 2015-01-04 17:14 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-14 08:58:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas J. Baker 2005-01-06 10:28:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
I've got a Dell 670n that I want to install fc3/64 on but I get a
kernel panic when the installer loads the ata_piix kernel module. I
can somewhat continue after the panic but installation hangs soon
after. Unfortunately, there's too much garbage on the screen when the
panic occurs for me to give a very much info on it. If you want, I can
try to grab a digital photo of the install screen.

I can boot the current x86_64 boot.img in the devel tree and that
works fine but when I point it at the non-devel fc3/64 tree, it won't
install that. If I use the standard fc3/64 boot disk with noprobe, I
get no keyboard so I can't continue. I want to run fc3/64. What's the
best way to get a newer kernel in an installer?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. try to install fc3/64 on this dell precision 670n
2.
3.
    

Actual Results:  kernel panic hang, install eventually locks up

Additional info:
Comment 1 Thomas J. Baker 2005-01-14 08:58:22 EST
More background. When I tried using the standard FC3 x86_64 install
disks, the sata controller would core dump and the installation would
fail. (I knew it was just a kernel version problem since a rawhide
boot disk would work but I didn't want to run rawhide.) 

When I used 'linux noprobe expert' I couldn't type because I had a usb
keyboard and mouse. I then added ps/2 stuff and using 'expert noprobe'
could then load the aic-79xx module but it wouldn't see my disk. After
trying to make a suitable boot disk using the latest kernel and
failing miserably, I ended up just installing a adaptec 2940uw to do
the install and after upgrading the kernel, moved back to the 79xx
which works perfectly.

Moral: if your mass storage controllers are too new for the install
media kernel, temporarily install older hardware...

Note You need to log in before you can comment on or make changes to this bug.