Bug 1443691 - Error when executing a button assigned to a button group
Summary: Error when executing a button assigned to a button group
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: API
Version: 5.8.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.9.0
Assignee: Tim Wade
QA Contact: Yadnyawalk Tale
URL:
Whiteboard: ssui
: 1441851 (view as bug list)
Depends On:
Blocks: 1452333
TreeView+ depends on / blocked
 
Reported: 2017-04-19 18:24 UTC by Shveta
Modified: 2018-03-06 15:16 UTC (History)
6 users (show)

Fixed In Version: 5.9.0.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1452333 (view as bug list)
Environment:
Last Closed: 2018-03-06 15:16:16 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)
errr (69.85 KB, image/png)
2017-04-19 18:24 UTC, Shveta
no flags Details
working_on_5.9.0.4.mp4 (2.49 MB, video/mp4)
2017-11-08 09:51 UTC, Yadnyawalk Tale
no flags Details

Description Shveta 2017-04-19 18:24:09 UTC
Created attachment 1272702 [details]
errr

Description of problem:


Version-Release number of selected component (if applicable):
5.8.0.11-beta2.20170418170914_a53d2a7

How reproducible:


Steps to Reproduce:
1. In OPS UI create a dialog (Automate - Customization)
2. Automate - Customization - Button - create a button group and a button under it .
3. in SUI , click on the service and execute the button . Shows error "Error submitting request"

Actual results:


Expected results:


Additional info:

Comment 2 Josh Langholtz 2017-04-20 15:50:05 UTC
Specifically, this error occurs for custom actions that belong to a generic custom button set. The SUI makes a request to the services endpoint for the custom_actions attribute and uses the buttons and button_groups properties to render the custom action buttons.

When the action is invoked, the API will correctly process the custom action if it unassigned (does not belong to a custom button set), however, if the same custom action is assigned to a generic custom button set, the exception will be raised.

The error message from the API is:

{"error":{"kind":"bad_request","message":"Unsupported Custom Action <custom action name> for the services resource specified","klass":"Api::BadRequestError"}}

Comment 4 Tim Wade 2017-04-22 19:22:59 UTC
*** Bug 1441851 has been marked as a duplicate of this bug. ***

Comment 5 Satoe Imaishi 2017-05-18 17:43:28 UTC
PR: https://github.com/ManageIQ/manageiq/pull/14845

Comment 7 Yadnyawalk Tale 2017-11-08 09:51:59 UTC
Created attachment 1349356 [details]
working_on_5.9.0.4.mp4

Working fine with this fix.
Verified on: 5.9.0.4.20171024163837_ef71ea6


Note You need to log in before you can comment on or make changes to this bug.