Bug 1443723 - SELinux is preventing systemd-localed from 'create' accesses on the file .#vconsole.conff67jvQ.
Summary: SELinux is preventing systemd-localed from 'create' accesses on the file .#vc...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 26
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:1b4d9e0befb87dce65daf6c1281...
Keywords:
: 1442675 1443725 1443726 (view as bug list)
Depends On:
Blocks: F26FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2017-04-19 20:28 UTC by Giulio 'juliuxpigface'
Modified: 2017-06-12 13:05 UTC (History)
11 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-06-12 13:05:56 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1440511 None None None Never

Internal Trackers: 1440511

Description Giulio 'juliuxpigface' 2017-04-19 20:28:23 UTC
Description of problem:
Found this on the live session of Fedora 26 Gnome (20160416 Workstation ISO), during the install of the system on qemu/kvm.
SELinux is preventing systemd-localed from 'create' accesses on the file .#vconsole.conff67jvQ.

*****  Plugin catchall_labels (83.8 confidence) suggests   *******************

If you want to allow systemd-localed to have create access on the .#vconsole.conff67jvQ file
Then you need to change the label on .#vconsole.conff67jvQ
Do
# semanage fcontext -a -t FILE_TYPE '.#vconsole.conff67jvQ'
where FILE_TYPE is one of the following: locale_t, xserver_etc_t.
Then execute:
restorecon -v '.#vconsole.conff67jvQ'


*****  Plugin catchall (17.1 confidence) suggests   **************************

If you believe that systemd-localed should be allowed create access on the .#vconsole.conff67jvQ file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'systemd-localed' --raw | audit2allow -M my-systemdlocaled
# semodule -X 300 -i my-systemdlocaled.pp

Additional Information:
Source Context                system_u:system_r:systemd_localed_t:s0
Target Context                system_u:object_r:etc_t:s0
Target Objects                .#vconsole.conff67jvQ [ file ]
Source                        systemd-localed
Source Path                   systemd-localed
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-249.fc26.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 4.11.0-0.rc6.git0.1.fc26.x86_64 #1
                              SMP Mon Apr 10 19:45:50 UTC 2017 x86_64 x86_64
Alert Count                   1
First Seen                    2017-04-19 16:21:46 EDT
Last Seen                     2017-04-19 16:21:46 EDT
Local ID                      853c8e53-b40a-4976-ae29-396703fab6d4

Raw Audit Messages
type=AVC msg=audit(1492633306.641:272): avc:  denied  { create } for  pid=18013 comm="systemd-localed" name=".#vconsole.conff67jvQ" scontext=system_u:system_r:systemd_localed_t:s0 tcontext=system_u:object_r:etc_t:s0 tclass=file permissive=1


Hash: systemd-localed,systemd_localed_t,etc_t,file,create

Version-Release number of selected component:
selinux-policy-3.13.1-249.fc26.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.9.1
hashmarkername: setroubleshoot
kernel:         4.11.0-0.rc6.git0.1.fc26.x86_64
type:           libreport

Potential duplicate: bug 919554

Comment 1 Giulio 'juliuxpigface' 2017-04-27 17:38:27 UTC
Proposing as a blocker for Fedora 26 Final.

The notification of SEAlert popped up (together with other 2/3 AVCs) after reaching the 100% of the installation of Fedora 26 Workstation.

This seems a violation of the "2.5.4 SELinux and crash notifications" criterion

"There must be no SELinux denial notifications or crash notifications on boot of or during installation from a release-blocking live image, or at first login after a default install of a release-blocking desktop."

https://fedoraproject.org/wiki/Fedora_26_Final_Release_Criteria#SELinux_and_crash_notifications

Comment 2 Geoffrey Marr 2017-05-01 18:34:05 UTC
Discussed during the 2017-05-01 blocker review meeting: [1]

The decision to classify this bug as an AcceptedBlocker was made as it violates the following blocker criteria:

"There must be no SELinux denial notifications or crash notifications on boot of or during installation from a release-blocking live image, or at first login after a default install of a release-blocking desktop."

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2017-05-01/f26-blocker-review.2017-05-01-16.02.txt

Comment 3 Lukas Vrabec 2017-05-17 10:14:38 UTC
*** Bug 1442675 has been marked as a duplicate of this bug. ***

Comment 4 Lukas Vrabec 2017-05-17 10:14:43 UTC
*** Bug 1443725 has been marked as a duplicate of this bug. ***

Comment 5 Lukas Vrabec 2017-05-17 10:14:48 UTC
*** Bug 1443726 has been marked as a duplicate of this bug. ***

Comment 6 Lukas Vrabec 2017-05-17 10:22:59 UTC
commit 9f9287509ef4b24d8640d79a7cd2631fe6638b56
Author: Lukas Vrabec <lvrabec@redhat.com>
Date:   Wed May 17 12:21:19 2017 +0200

    Allow systemd_localed_t and systemd_timedated_t create files in /etc with label locate_t BZ(1443723)

Comment 7 Alessio 2017-06-01 09:33:20 UTC
Description of problem:
Workstation Live Beta 1.4 installation

Version-Release number of selected component:
selinux-policy-3.13.1-251.fc26.noarch

Additional info:
reporter:       libreport-2.9.1
hashmarkername: setroubleshoot
kernel:         4.11.0-2.fc26.x86_64
type:           libreport

Comment 8 Fedora Update System 2017-06-08 11:10:27 UTC
selinux-policy-3.13.1-257.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-6a43388229

Comment 9 Fedora Update System 2017-06-10 01:09:54 UTC
selinux-policy-3.13.1-257.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-6a43388229

Comment 10 Fedora Update System 2017-06-12 13:05:56 UTC
selinux-policy-3.13.1-257.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.