Bug 144377 - TypeError: GtkWindow.set_icon() argument 1 must be gtk.gdk.Pixbuf, not None
Summary: TypeError: GtkWindow.set_icon() argument 1 must be gtk.gdk.Pixbuf, not None
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-samba   
(Show other bugs)
Version: 3.0
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-06 17:13 UTC by Chris Pepper
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 19:09:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
debugging version of mainWindow.py (13.84 KB, text/plain)
2005-01-11 15:28 UTC, Nils Philippsen
no flags Details
python script to test gtk.gdk.pixbuf* (167 bytes, text/plain)
2005-01-11 17:29 UTC, Nils Philippsen
no flags Details

Description Chris Pepper 2005-01-06 17:13:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-us) AppleWebKit/125.5.5 (KHTML, like Gecko) Safari/125.12

Description of problem:
On a freshly up2date'd system, redhat-config-samba fails to run with a traceback.

[root@preview root]# redhat-config-samba
Traceback (most recent call last):
  File "/usr/share/redhat-config-samba/redhat-config-samba.py", line 20, in ?
    mainWindow.MainWindow(debug_flag)
  File "/usr/share/redhat-config-samba/mainWindow.py", line 53, in __init__
    self.main_window.set_icon(iconPixbuf)
TypeError: GtkWindow.set_icon() argument 1 must be gtk.gdk.Pixbuf, not None
[root@preview root]# uname -a
Linux preview.rockefeller.edu 2.4.21-20.0.1.ELsmp #1 SMP Wed Nov 24 20:34:01 EST


Version-Release number of selected component (if applicable):
redhat-config-samba-1.0.16-2

How reproducible:
Always

Steps to Reproduce:
1. redhat-config-samba
    

Actual Results:  Traceback

Expected Results:  See the r-c-s GUI

Additional info:

Comment 1 Nils Philippsen 2005-01-11 14:16:22 UTC
This works for me with the same redhat-config-samba version.

Does the file /usr/share/redhat-config-samba/pixmaps/redhat-config-samba.png
exist and is it readable? What do the following commands give?

- "rpm -q redhat-config-samba"
- "rpm -V redhat-config-samba"

Comment 2 Chris Pepper 2005-01-11 15:10:57 UTC
The file is there, but I still get a traceback.

[root@preview root]# ls -l /usr/share/redhat-config-samba/pixmaps/redhat-config-samba.png
-rwxr-xr-x    1 root     root         3289 Aug  3 02:57 /usr/share/redhat-config-samba/pixmaps/
redhat-config-samba.png
[root@preview root]# rpm -q redhat-config-samba
redhat-config-samba-1.0.16-2
[root@preview root]# rpm -V redhat-config-samba
[root@preview root]# uname -a
Linux preview.rockefeller.edu 2.4.21-20.0.1.ELsmp #1 SMP Wed Nov 24 20:34:01 EST 2004 i686 i686 
i386 GNU/Linux

[root@preview root]# redhat-config-samba 
Traceback (most recent call last):
  File "/usr/share/redhat-config-samba/redhat-config-samba.py", line 20, in ?
    mainWindow.MainWindow(debug_flag)
  File "/usr/share/redhat-config-samba/mainWindow.py", line 53, in __init__
    self.main_window.set_icon(iconPixbuf)
TypeError: GtkWindow.set_icon() argument 1 must be gtk.gdk.Pixbuf, not None

Comment 3 Nils Philippsen 2005-01-11 15:28:29 UTC
Created attachment 109612 [details]
debugging version of mainWindow.py

Please save a backup of the redhat-config-samba package (or
/usr/share/redhat-config-samba/mainWindow.py) and place this version of
mainWindow.py into the /usr/share/redhat-config-samba directory, then try again
and tell me what error messages if any you see.

Comment 4 Chris Pepper 2005-01-11 15:58:28 UTC
[root@preview root]# redhat-config-samba 
Traceback (most recent call last):
  File "/usr/share/redhat-config-samba/redhat-config-samba.py", line 19, in ?
    import mainWindow
  File "/usr/share/redhat-config-samba/mainWindow.py", line 30, in ?
    iconPixbuf = gtk.gdk.pixbuf_new_from_file("/usr/share/redhat-config-samba/pixmaps/redhat-
config-samba.png")
gobject.GError: Couldn't recognize the image file format for file '/usr/share/redhat-config-samba/
pixmaps/redhat-config-samba.png'
[root@preview root]# ls -l /usr/share/redhat-config-samba/pixmaps/redhat-config-samba.png
-rwxr-xr-x    1 root     root         3289 Aug  3 02:57 /usr/share/redhat-config-samba/pixmaps/
redhat-config-samba.png
[root@preview root]# md5 /usr/share/redhat-config-samba/pixmaps/redhat-config-samba.png
-bash: md5: command not found
[root@preview root]# md5sum /usr/share/redhat-config-samba/pixmaps/redhat-config-samba.png
241c9dc219b87341f8949c9f9ef4b20f  /usr/share/redhat-config-samba/pixmaps/redhat-config-
samba.png
[root@preview root]# file /usr/share/redhat-config-samba/pixmaps/redhat-config-samba.png
/usr/share/redhat-config-samba/pixmaps/redhat-config-samba.png: PNG image data, 48 x 48, 8-bit/
color RGBA, non-interlaced


Comment 5 Nils Philippsen 2005-01-11 17:29:25 UTC
Created attachment 109622 [details]
python script to test gtk.gdk.pixbuf*

Please restore the backup mainWindow.py to its original place and see whether
you get a similar error with the attached test case:

python pixbuftest.py

Comment 6 Chris Pepper 2005-01-11 18:14:44 UTC
[root@preview pepper]# python pixbuftest.py 
Traceback (most recent call last):
  File "pixbuftest.py", line 6, in ?
    iconPixbuf = gtk.gdk.pixbuf_new_from_file("/usr/share/redhat-config-samba/pixmaps/redhat-
config-samba.png")
gobject.GError: Couldn't recognize the image file format for file '/usr/share/redhat-config-samba/
pixmaps/redhat-config-samba.png'
[root@preview pepper]# which python
/usr/bin/python
[root@preview pepper]# python --version
Unknown option: --
usage: python [option] ... [-c cmd | file | -] [arg] ...
Try `python -h' for more information.
[root@preview pepper]# python -V
Python 2.2.3


Comment 7 Nils Philippsen 2005-01-12 08:35:59 UTC
It seems something in gdk-pixbuf doesn't work OK. What version do you have and
does it verify correctly?

- "rpm -q gdk-pixbuf"
- "rpm -V gdk-pixbuf"

Comment 8 Chris Pepper 2005-01-12 21:45:54 UTC
No complaints:

[root@preview root]# rpm -V gdk-pixbuf
[root@preview root]# rpm -q gdk-pixbuf
gdk-pixbuf-0.22.0-11.3.3


Comment 9 Nils Philippsen 2006-06-07 12:21:42 UTC
With current updates applied, does this bug still show?

Comment 10 Chris Pepper 2007-08-22 13:50:25 UTC
It looks like this is still present.

[root@preview root]# rpm -q gdk-pixbuf redhat-config-samba
gdk-pixbuf-0.22.0-13.el3.3
redhat-config-samba-1.0.16-5
[root@preview root]# rpm -V gdk-pixbuf redhat-config-samba
[root@preview root]# up2date -l gdk-pixbuf redhat-config-samba

Fetching Obsoletes list for channel: rhel-i386-as-3...
########################################

Fetching rpm headers...
########################################

Name                                    Version        Rel     
----------------------------------------------------------


The following packages you requested are already updated:
gdk-pixbuf
redhat-config-samba
[root@preview root]# 


Comment 11 Nils Philippsen 2007-08-27 09:02:14 UTC
Chris, please run the pixbuftest.py script again and post its output. Thanks.

Comment 12 Chris Pepper 2007-08-28 15:41:06 UTC
[root@preview root]# python ~pepper/pixbuftest.py 
Traceback (most recent call last):
  File "/home/pepper/pixbuftest.py", line 6, in ?
    iconPixbuf = gtk.gdk.pixbuf_new_from_file("/usr/share/redhat-config-samba/pixmaps/redhat-
config-samba.png")
gobject.GError: Couldn't recognize the image file format for file '/usr/share/redhat-config-samba/
pixmaps/redhat-config-samba.png'
[root@preview root]# ls -l /usr/share/redhat-config-samba/pixmaps/redhat-config-samba.png
-rwxr-xr-x    1 root     root         3289 Jul 29  2005 /usr/share/redhat-config-samba/pixmaps/redhat-
config-samba.png
[root@preview root]# file /usr/share/redhat-config-samba/pixmaps/redhat-config-samba.png
/usr/share/redhat-config-samba/pixmaps/redhat-config-samba.png: PNG image data, 48 x 48, 8-bit/
color RGBA, non-interlaced
[root@preview root]# md5sum /usr/share/redhat-config-samba/pixmaps/redhat-config-samba.png
241c9dc219b87341f8949c9f9ef4b20f  /usr/share/redhat-config-samba/pixmaps/redhat-config-
samba.png

Comment 13 RHEL Product and Program Management 2007-10-19 19:09:47 UTC
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.


Note You need to log in before you can comment on or make changes to this bug.