Bug 1443926 - Iso image written to a media instead of raw image.
Summary: Iso image written to a media instead of raw image.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mediawriter
Version: 26
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
Assignee: Martin Bříza
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1445078 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-20 09:24 UTC by Peter Kotvan
Modified: 2017-06-09 19:01 UTC (History)
2 users (show)

Fixed In Version: mediawriter-4.1.0-1.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-09 19:01:57 UTC


Attachments (Terms of Use)

Description Peter Kotvan 2017-04-20 09:24:05 UTC
Description of problem:
I've tried to use media writer to write an armv7 image to an SD card. I have a Banana Pi device.

The download and the writing of the image went without any problem but I was unable to boot.

The output of lsblk -f showed that there is an iso on the SD card:

NAME                             FSTYPE      LABEL                     UUID
mmcblk0                          iso9660     Fedora-S-dvd-armhfp-25    2016-11-15-20-05-15-00

Steps to Reproduce:
1. Use Fedora Media Writer to write an armv7 image.

Actual results:
Iso image is written to the device.

Expected results:
Raw image is written to the device.

Additional info:

Comment 1 Peter Kotvan 2017-04-20 10:19:12 UTC
Version: mediawriter-4.0.95-1.fc26.x86_64

Comment 2 Peter Kotvan 2017-04-20 10:37:25 UTC
I've continued with the testing and found out that this only happens for the Server. In the case of writing a Workstation image the raw image is used as expected... not the iso image.

Comment 3 Peter Kotvan 2017-04-20 10:57:39 UTC
I've tested it with usb flash storage ans with SD card as well. The behaviour was the same for both.

Comment 4 Peter Kotvan 2017-04-20 10:59:46 UTC
I'd suggest that in the Write Fedora Server/Workstation dialog there should be shown the exact name of the image intended to write so the user can verify which one is actually written. 

Right now media writer claimed to install the raw image but actually it wrote an iso (as described before).

Comment 5 Martin Bříza 2017-04-20 11:01:33 UTC
This problem is already solved upstream. It was a bug in the parser of the list of images fetched from the Fedora servers.
Thank you for reporting.

Comment 6 Martin Bříza 2017-04-25 08:35:43 UTC
*** Bug 1445078 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Update System 2017-05-18 14:50:36 UTC
mediawriter-4.1.0-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-729cc5d719

Comment 8 Fedora Update System 2017-05-19 21:09:38 UTC
mediawriter-4.1.0-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-729cc5d719

Comment 9 Fedora Update System 2017-06-09 19:01:57 UTC
mediawriter-4.1.0-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.