Bug 1444030 - No warning is showed when there is insufficient space on the drive.
Summary: No warning is showed when there is insufficient space on the drive.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mediawriter
Version: 26
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Bříza
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-20 13:03 UTC by Peter Kotvan
Modified: 2017-06-09 19:02 UTC (History)
1 user (show)

Fixed In Version: mediawriter-4.1.0-1.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-09 19:02:00 UTC


Attachments (Terms of Use)

Description Peter Kotvan 2017-04-20 13:03:36 UTC
Description of problem:
I tried to download an image with insufficient space on /home. Media Writer started the download without any warning and ended with following message:

The downloaded image is corrupted
Download failed

Version-Release number of selected component (if applicable):
mediawriter-4.0.95-1.fc26.x86_64

Steps to Reproduce:
1. Try to download an image with insufficient space on /home partition.

Actual results:
Failed download without any information why it failed.

Expected results:
Ideally the Media Writer checks if there is enough space on the target device. Also report that the download failed because of insufficient space if this is actually the case.

It would be great to allow the user to select the target folder on her/his own.

Comment 1 Martin Bříza 2017-04-24 09:04:01 UTC
I'll think about this. Adding another element to the UI for a corner case doesn't seem right.

Comment 2 Peter Kotvan 2017-04-24 09:08:53 UTC
I think that more specific error message is a good idea. 

Possibility to choose the destination could be considered as a bonus feature. :)

Comment 3 Martin Bříza 2017-04-24 09:19:46 UTC
Yeah, the message is a definite yes. I'm adding it today.

Comment 4 Martin Bříza 2017-04-24 13:23:23 UTC
Fixed partially (for iso images, not for raw ones).

Comment 5 Martin Bříza 2017-04-24 13:25:19 UTC
Mistaken the report, it should have been #1444058. Going to fix this now so I can leave POST Here.

Comment 6 Fedora Update System 2017-05-18 14:50:42 UTC
mediawriter-4.1.0-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-729cc5d719

Comment 7 Fedora Update System 2017-05-19 21:09:42 UTC
mediawriter-4.1.0-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-729cc5d719

Comment 8 Fedora Update System 2017-06-09 19:02:00 UTC
mediawriter-4.1.0-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.