Bug 1444058 - Media is written even if it is smaller than the image.
Summary: Media is written even if it is smaller than the image.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mediawriter
Version: 26
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: Martin Bříza
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-20 13:38 UTC by Peter Kotvan
Modified: 2017-06-09 19:02 UTC (History)
1 user (show)

Fixed In Version: mediawriter-4.1.0-1.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-09 19:02:03 UTC


Attachments (Terms of Use)

Description Peter Kotvan 2017-04-20 13:38:13 UTC
Description of problem:
I tried to write an image to a 1G flash drive. Even though the image was bigger and the Media Writer showed that the media is too small it started the write process.

When there is no space left following message is shown:

Destination drive is not writable

Version-Release number of selected component (if applicable):
mediawriter-4.0.95-1.fc26.x86_64

Steps to Reproduce:
1. Try to write the image on the media that is too small.

Actual results:
The write process starts even there is not enough space on the media and it ends with unspecific error message.

Expected results:
Don't start the write process if the media is too small.

Comment 1 Martin Bříza 2017-04-24 09:05:02 UTC
This is a problem because for ARM images there is no information about how much space will be necessary. I'll have to add some code querying the archive for the final size (if that's even possible) and then fix this issue.
However, it's planned.

Comment 2 Martin Bříza 2017-04-24 13:25:09 UTC
Fixed for x86 images. ARM coming at some point in the future.

Comment 3 Fedora Update System 2017-05-18 14:50:47 UTC
mediawriter-4.1.0-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-729cc5d719

Comment 4 Fedora Update System 2017-05-19 21:09:45 UTC
mediawriter-4.1.0-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-729cc5d719

Comment 5 Fedora Update System 2017-06-09 19:02:03 UTC
mediawriter-4.1.0-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.