Bug 1444147 - OSP10 -> OSP11 upgrade fails during major-upgrade-composable-steps.yaml when nodes are registered to Satellite 6
Summary: OSP10 -> OSP11 upgrade fails during major-upgrade-composable-steps.yaml when...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-heat-agents
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: 11.0 (Ocata)
Assignee: Steve Baker
QA Contact: Arik Chernetsky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-20 16:46 UTC by Marius Cornea
Modified: 2017-05-17 20:23 UTC (History)
7 users (show)

Fixed In Version: openstack-heat-agents-1.0.1-1.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 20:23:35 UTC


Attachments (Terms of Use)
openstack stack failures list (31.42 KB, text/plain)
2017-04-20 16:48 UTC, Marius Cornea
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC

Description Marius Cornea 2017-04-20 16:46:50 UTC
Description of problem:
OSP10 -> OSP11 upgrade fails during major-upgrade-composable-steps.yaml when nodes are registered to Satellite 6 with:

  deploy_stderr: |
    Legacy hieradata from os-apply-config has been detected. Please update all of your interfaces to use the new heat-agents hiera hook before proceeding

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-6.0.0-5.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy OSP10 with nodes registered to Satallite 6
2. Upgrade to OSP11

Actual results:
Upgrade fails with   deploy_stderr: |
    Legacy hieradata from os-apply-config has been detected. Please update all of your interfaces to use the new heat-agents hiera hook before proceeding

Expected results:
Upgrade completes ok.

Additional info:

Comment 1 Marius Cornea 2017-04-20 16:48:19 UTC
Created attachment 1273029 [details]
openstack stack failures list

Comment 2 Marius Cornea 2017-04-20 16:49:07 UTC
Environment files:

source ~/stackrc
export THT=/usr/share/openstack-tripleo-heat-templates/

openstack overcloud deploy --templates $THT \
-e $THT/environments/network-isolation.yaml \
-e $THT/environments/network-management.yaml \
-e $THT/environments/storage-environment.yaml \
-e $THT/extraconfig/pre_deploy/rhel-registration/rhel-registration-resource-registry.yaml \
-e ~/openstack_deployment/environments/satellite-6.yaml \
-e ~/openstack_deployment/environments/nodes.yaml \
-e ~/openstack_deployment/environments/network-environment.yaml \
-e ~/openstack_deployment/environments/disk-layout.yaml \
-e ~/openstack_deployment/environments/neutron-settings.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/major-upgrade-composable-steps.yaml \
-e ~/repo.yaml \
--log-file overcloud_deployment.log &> overcloud_install.log

Comment 4 Sofer Athlan-Guyot 2017-04-20 16:56:18 UTC
Hi,

so the package on sat6 is not up to date and doesn't include the patch in https://bugzilla.redhat.com/show_bug.cgi?id=1439121 with the openstack-heat-agents-1.0.1-1.el7ost

Comment 5 Sofer Athlan-Guyot 2017-04-20 17:02:47 UTC
<mcornea> chem: sasha I see right now we have openstack-heat-agents.noarch
          1.0.0-3.el7ost
          @rhel-7-server-openstack-beta-rpms

So we have to have sat6 package updated to the latest version.

Comment 6 Sofer Athlan-Guyot 2017-04-20 17:40:51 UTC
So according to Mike "we need to re-push to stage, then resync satellite".  Pushing this modified with the correct needed build.

Comment 8 Jaromir Coufal 2017-04-24 15:22:49 UTC
Verbally acked by LT team (hbrock) on Apr 24, 2017. Granting pm_ack+ based on that.

Comment 11 errata-xmlrpc 2017-05-17 20:23:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.