Bug 1444200 - Template descriptions not showing up in web console
Summary: Template descriptions not showing up in web console
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.5.z
Assignee: Samuel Padgett
QA Contact: XiaochuanWang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-20 19:45 UTC by Samuel Padgett
Modified: 2017-05-18 09:28 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Template descriptions were not displayed in the web console catalog (after clicking "Add to Project"). Only the name was displayed. The problem has been fixed, and template descriptions correctly display in the tiles when browsing the catalog and in the page header when instantiating a template.
Clone Of:
Environment:
Last Closed: 2017-05-18 09:28:44 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1235 0 normal SHIPPED_LIVE OpenShift Container Platform 3.5, 3.4, 3.3, and 3.1 bug fix update 2017-05-18 13:15:52 UTC

Description Samuel Padgett 2017-04-20 19:45:33 UTC
Template descriptions are no longer showing up in the web console. This was caused by 

https://github.com/openshift/origin-web-console/pull/1147

The web console `description` filter should also look for `metadata.annotations.description`.

Comment 2 Troy Dawson 2017-04-24 16:21:53 UTC
This has been merged into ocp and is in OCP v3.5.5.9 or newer.

Comment 4 Samuel Padgett 2017-04-24 20:37:59 UTC
The fix for 3.6 is included in https://github.com/openshift/origin-web-console/pull/1469

Comment 5 XiaochuanWang 2017-04-25 02:47:54 UTC
Verified on OCP v3.5.5.9
Description displays well in project list page.

Comment 6 Samuel Padgett 2017-04-25 11:56:26 UTC
(In reply to XiaochuanWang from comment #5)
> Description displays well in project list page.

The fix is for template descriptions from the add to project catalog. They should display on the tiles after clicking one of the categories and then one the template page when one is selected.

Comment 7 XiaochuanWang 2017-04-26 01:50:13 UTC
Thanks for explaining detail this bug, verified on v3.5.5.9

Using https://raw.githubusercontent.com/openshift/origin/master/examples/sample-app/application-template-stibuild.json with template description displays well when select Ruby in Catalog page by clicking Add-to-Project.

Item displays as following which is expected.
"""
 ruby-helloworld-sample

This example shows how to create a simple ruby application in openshift origin v3

Namespace: xiaocwan-t 
"""

Comment 9 errata-xmlrpc 2017-05-18 09:28:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1235


Note You need to log in before you can comment on or make changes to this bug.