Bug 1444229 - Kernel 4.10.10 new 'button.lid_init_state' setting causes issues with Dell docking stations
Summary: Kernel 4.10.10 new 'button.lid_init_state' setting causes issues with Dell do...
Keywords:
Status: CLOSED DUPLICATE of bug 1430259
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 25
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-20 22:50 UTC by Gijs Roeffen
Modified: 2017-04-25 09:33 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-25 09:33:34 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Linux Kernel 187271 None None None 2017-04-25 09:26:44 UTC

Description Gijs Roeffen 2017-04-20 22:50:21 UTC
Description of problem:

When our Fedora workstations (Dell XPS 15 / XPS 13 / Precision 5510 / 5520) together with the Dell WD15 / TB16 dock upgraded to kernel 4.10.10-200 on Fedora 25 the docking mechanism broke. Now when the systems are booted they *always* think the lid is open whilst its closed causing suspend/resume issues and booting up with the onscreen display active whilst the laptop is closed and docked.

This seems to be caused by the patch commited on Jan 12;

https://patchwork.kernel.org/patch/9512307/

Reverting the 'new' lid behavior to the "previous" (< 4.10.10) ) to "button.lid_init_state=method" seems to fix this issue.

Version-Release number of selected component (if applicable):
25

How reproducible:
1. Obtain a Dell laptop with a WD15 and/or TB16 dock.
2. Upgrade to kernel 4.10.10 (Upto 4.10.9 works fine).

Steps to Reproduce:
1.
2.
3.

Actual results:
Laptop always activates the onscreen display and keeps the laptop on-line/

Expected results:
Reflect the actual state of the lid (closed/open when docked)

Additional info:

Comment 1 Joachim Frieben 2017-04-25 09:26:18 UTC
Duplicate of bug 1430259, now also affecting Fedora 25 since kernel 4.10.10.

Comment 2 Gijs Roeffen 2017-04-25 09:33:34 UTC

*** This bug has been marked as a duplicate of bug 1430259 ***


Note You need to log in before you can comment on or make changes to this bug.