Bug 144431 - Many incorrect patch files in the source RPM ?
Summary: Many incorrect patch files in the source RPM ?
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-06 22:49 UTC by Jørgen Thomsen
Modified: 2015-01-04 22:15 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-06 23:06:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jørgen Thomsen 2005-01-06 22:49:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1) Opera 
7.54  [en]

Description of problem:
I noticed by manually running the patches in the package, that they 
produced 171 FAILED messages along with a lot of succesfull patches. 
I also noticed, that at least one failed patch file definitely did 
not have the linux-2.6.9 file as its source. After studying more how 
to compile the source I succesfully ran the steps, but I am wondering 
if the failing patches were just ignored and if I now have an 
unstable kernel in an undefined state not equal to 2.6.9-1.681_FC3 
with my tiny change of one variable.


BTW as mentioned in another report: a HOWTO compile document is 
highly needed with the source.
Version-Release number of selected component (if applicable):
src RPM for 2.6.9-1.681_FC3

How reproducible:
Always

Steps to Reproduce:
1. run patches of the src RPM manually 
2.
3.
    

Actual Results:  many FAILED messages

Expected Results:  all success

Additional info:

Comment 1 Dave Jones 2005-01-06 23:06:36 UTC
I don't know what you did, but you're doing something wrong.
I've done hundreds of local builds without error, and the build system
wouldn't spit out binary rpm's if something went wrong in the patching
process.


Comment 2 Warren Togami 2005-01-07 00:26:22 UTC
He probably was trying to patch manually, and it failed because one
patch relies upon another.


Note You need to log in before you can comment on or make changes to this bug.