Bug 14444 - boot.net + kickstart problem
boot.net + kickstart problem
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
high Severity low
: ---
: ---
Assigned To: Erik Troan
Winston gold
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-21 16:56 EDT by Matt Domsch
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-22 17:15:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kickstart file (2.80 KB, text/plain)
2000-07-21 16:57 EDT, Matt Domsch
no flags Details

  None (edit)
Description Matt Domsch 2000-07-21 16:56:49 EDT
Anaconda developers, keep up the great work!

I put a kickstart file on the beta4 bootnet.img file, and called it 
with 'expert ks=floppy'.  The /proc/cmdline showed up as:
expert ks=floppy initrd=initrd.img devfs=nomount BOOT_IMAGE=vmlinuz auto

The installer gave me the "No Drives Found" message.  Strange, I thought.  
It did the NFS mount properly.  Messages on VT3 say:
* unknown module aic7xxx
* unexpected arguments to device probe command (note, I didn't specify 
deviceprobe command)
* forcing device probe
* kickstarting through device eth0
* sending dhcp request through device eth0
* nodns is 0
* revers name lookup failed
* going to insmod sunrpc.o (path is NULL)
* going to insmod lockd.o (path is NULL)
* going to insmod nfs.o (path is NULL)
* mounting nfs path .....
* found information on module eepro100 (specified in the ks.cfg)
* unknown module aacraid (specified in the ks.cfg)
* unknown module aic7xxx (specified in the ks.cfg)
* unexpected arguments to deviceprobe command
* forcing device probe
* getting ready to spawn shell now
* going to insmod raid[015].o,ext3.o (path is NULL)
* looking for USB mouse...
* no IDE floppy devices found

It's the unknown module {aacraid, aic7xxx} that concern me.  At this point 
I get the "No Drives Found" message, which is unexpected because the NFS 
instimage has already been mounted, and the modules.cgz file is 
at /modules/modules.cgz -> ../mnt/runtime/modules/modules.cgz.  When I 
uncpio that into the /tmp directory, the aacraid and aic7xxx drivers *are* 
there.

If I do this:
cd /tmp/
uncpio < /mnt/runtime/modules/modules.cgz
I get the error: cpio filaed on 2.2.16-12BOOT/dgrs.o: Success.  My guess 
is this is innocent, as I ran out of room on the initrd.  In any case, 
then in the 2.2.16-12BOOT directory, aic7xxx and aacraid are both there.  
So, why didn't this work?  ks.cfg attached.
Comment 1 Matt Domsch 2000-07-21 16:57:35 EDT
Created attachment 1447 [details]
kickstart file
Comment 2 Matt Domsch 2000-07-21 17:47:18 EDT
Fails the same way with beta 3.  Cannot go back to beta 2, as the aacraid 
driver wasn't on the CD then.

Note, using the bootnet.img and an hand expert GUI install, I can select the 
aacraid and aic7xxx drivers myself and it works just fine.  It's only with 
kickstart that it doesn't load the driver.
Comment 3 Matt Domsch 2000-07-27 15:42:36 EDT
Same with pinstripe.  Note that plain 'linux ks=floppy' with the same ks.cfg 
works just fine.  What we lose (it seems) is the ability to use the noprobe.  
Since 'linux ks=floppy' works, and 'expert ks=floppy' doesn't, I'm dropping the 
severity on this to low.
Comment 4 Matt Domsch 2000-08-11 14:36:34 EDT
I'd like to have the noprobe option back, if at all possible.  Can you revert 
out the deviceprobe code?
Comment 5 Glen Foster 2000-08-22 15:39:03 EDT
This defect is considered MUST-FIX for Winston Gold release
Comment 6 Erik Troan 2000-08-22 16:40:45 EDT
Fix sent to Matt Domsch
Comment 7 Matt Domsch 2000-08-22 17:15:45 EDT
Indeed, the provided boot.img works with noprobe nicely.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.