Bug 144446 - RPM has dependencies on SELinux
RPM has dependencies on SELinux
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-06 22:59 EST by Leif Hedstrom
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-27 17:32:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leif Hedstrom 2005-01-06 22:59:22 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
While trying to do some "rawhide" upgrades, my yum stopped working
with an error like complaining about a missing symbol rpm_execcon. It
turns out I was allowed to upgrade rpm and fellow packages, but it did
not upgrade libselinux properly.

Would it maybe make sense to have a version dependency on libselinux
in the SPEC file for the rpm packages?

Version-Release number of selected component (if applicable):
rpm-4.3.3-8 and/or rpm-libs-4.3.3-8

How reproducible:
Always

Steps to Reproduce:
1. Upgraded RPM
2. Tried to run yum
3. yum fails to load the python module rpmmodule.so, missing the
rpm_execcon symbol
    

Additional info:
Comment 1 Paul Nasrat 2005-09-27 17:32:38 EDT
API symbol changes in selinux should have a soname change - rpm in rawhide has a
library requirement on libselinux.so.1

Current rawhide should be working correctly.  This seems to have just been a
rawhide in flux bug

Note You need to log in before you can comment on or make changes to this bug.