Bug 1444467 - "waf install" triggers rebuild of Vala app
Summary: "waf install" triggers rebuild of Vala app
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: waf
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Thomas Moschny
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-21 11:59 UTC by Vít Ondruch
Modified: 2017-05-02 23:14 UTC (History)
2 users (show)

Fixed In Version: waf-1.9.10-1.fc26 waf-1.9.10-1.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-01 18:15:06 UTC


Attachments (Terms of Use)
[PATCH] Exclude install vapi paths and empty installation tasks (2.33 KB, application/mbox)
2017-04-21 11:59 UTC, Vít Ondruch
no flags Details


Links
System ID Priority Status Summary Last Updated
Github waf-project waf issues 1948 None None None 2017-04-21 12:00:45 UTC
Red Hat Bugzilla 1441816 None None None Never

Internal Links: 1441816

Description Vít Ondruch 2017-04-21 11:59:43 UTC
Created attachment 1273308 [details]
[PATCH] Exclude install vapi paths and empty installation tasks

Description of problem:
There is bug in waf 1.9.9 due to which "waf install" triggers rebuild of some files in Vala application [1]. Would you mind to include [2] to fix this issue? The backported patch is included.


Version-Release number of selected component (if applicable):
$ rpm -q waf
waf-1.9.9-1.fc27.noarch


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:


[1]: https://github.com/waf-project/waf/issues/1948
[2]: https://github.com/waf-project/waf/commit/3de21ec448eb428d001a4d9d9af51958947345d6

Comment 1 Fedora Update System 2017-04-23 13:58:35 UTC
waf-1.9.10-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-77bfce63fb

Comment 2 Fedora Update System 2017-04-23 13:58:50 UTC
waf-1.9.10-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-a5ba4f7670

Comment 3 Vít Ondruch 2017-04-24 07:32:28 UTC
Yep, that should solve the issue as well ;) Thx.

Comment 4 Fedora Update System 2017-04-25 03:53:09 UTC
waf-1.9.10-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-77bfce63fb

Comment 5 Fedora Update System 2017-04-25 21:27:33 UTC
waf-1.9.10-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-a5ba4f7670

Comment 6 Fedora Update System 2017-05-01 18:15:06 UTC
waf-1.9.10-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2017-05-02 23:14:47 UTC
waf-1.9.10-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.