Bug 1444512 - GUI : Facts dialogue displays the consumer id of the system that is already deleted at server side
Summary: GUI : Facts dialogue displays the consumer id of the system that is already d...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.4
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Jiri Hnidek
QA Contact: Jan Stavel
URL:
Whiteboard:
Depends On: 1510727 1511804
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-21 13:25 UTC by Shwetha Kallesh
Modified: 2018-04-10 09:49 UTC (History)
5 users (show)

Fixed In Version: subscription-manager-1.20.2-1
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-04-10 09:49:05 UTC


Attachments (Terms of Use)
System Identity section displays consumer id even though the consumer is deleted (220.65 KB, image/png)
2017-04-21 13:25 UTC, Shwetha Kallesh
no flags Details
"System Identity" now displays the deleted UUID (243.81 KB, image/png)
2018-01-02 10:46 UTC, Shwetha Kallesh
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0681 None None None 2018-04-10 09:49:28 UTC
Github candlepin subscription-manager pull 1611 None None None 2017-04-28 12:27:22 UTC

Description Shwetha Kallesh 2017-04-21 13:25:57 UTC
Created attachment 1273323 [details]
System Identity section displays consumer id even though the consumer is deleted

Description of problem:
Facts dialogue displays the consumer id of the system that is already deleted at server side on the top of the box in Identity section


Version-Release number of selected component (if applicable):
[root@cisco-b200m1-03 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 2.1.0-1
subscription management rules: 5.23
subscription-manager: 1.19.9-1.git.0.46ef55e.el7
python-rhsm: 1.19.5-1.git.17.46ef55e.el7


How reproducible:


Steps to Reproduce:
1. Register the system

[root@cisco-b200m1-03 ~]# subscription-manager register --force
The system with UUID 7562b74e-bd81-4977-ba98-44a27481389e has been unregistered
Registering to: Shwetha-candlepin.usersys.redhat.com:8443/candlepin
Username: admin
Password: 
Organization: admin
The system has been registered with ID: 9d304d8b-634a-4011-b39a-7747250d963a 

2.Delete the consumer on the server 

[root@cisco-b200m1-03 ~]# curl -k -u admin:admin --request DELETE https://Shwetha-candlepin.usersys.redhat.com:8443/candlepin/consumers/9d304d8b-634a-4011-b39a-7747250d963a


3. Check the system identity on CLI , it looks fine
[root@cisco-b200m1-03 ~]# subscription-manager identity
Unit 9d304d8b-634a-4011-b39a-7747250d963a has been deleted

4. now launch GUI and go to systems ----> view system facts 


Actual results:
System Identity : 9d304d8b-634a-4011-b39a-7747250d963a
P.S : 

Expected results:
Unit 9d304d8b-634a-4011-b39a-7747250d963a has been deleted

Additional info:

Comment 2 Kevin Howell 2017-04-24 14:33:00 UTC
Note to dev: let's investigate behavior in this state, and possibly use this bug to address any inconsistencies.

Comment 3 Jiri Hnidek 2017-04-28 12:27:23 UTC
I can confirm that I'm able to reproduce this bug.

Comment 7 Jan Stavel 2017-12-06 10:25:36 UTC
Hello, I cannot make subscription-manager-gui run in such case.

After I delete the consumer
and I run subscription-manager-gui from console
then I see "Unit ........ has been deleted" 
and no application window raises.

If I run subscription-manager-gui using window menu
then I see nothing appeared on a screen.

Comment 8 Jan Stavel 2017-12-06 10:29:24 UTC
subscription-manager-rhsm-certificates-1.20.7-1.el7.x86_64
subscription-manager-gui-1.20.7-1.el7.x86_64
subscription-manager-plugin-container-1.20.7-1.el7.x86_64
subscription-manager-rhsm-1.20.7-1.el7.x86_64
subscription-manager-1.20.7-1.el7.x86_64
subscription-manager-initial-setup-addon-1.20.7-1.el7.x86_64

Comment 9 Kevin Howell 2017-12-07 15:17:39 UTC
Let's re-verify once bug 1510727 has been fixed.

Comment 11 Shwetha Kallesh 2018-01-02 10:46:22 UTC
Created attachment 1375617 [details]
"System Identity" now displays the deleted UUID

Moving bug to verified as facts dialogue now displays deleted UUID

[root@bkr-hv01-guest13 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 2.2.0-1
subscription management rules: 5.26
subscription-manager: 1.20.9-1.el7

Comment 14 errata-xmlrpc 2018-04-10 09:49:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0681


Note You need to log in before you can comment on or make changes to this bug.