Bug 144455 - other tk-related programs cannot detect tk.tcl
other tk-related programs cannot detect tk.tcl
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: blt (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jean-Luc Fontaine
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-07 05:33 EST by Takanori MATSUURA
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-03 07:05:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix this bug (918 bytes, patch)
2005-01-07 05:35 EST, Takanori MATSUURA
no flags Details | Diff

  None (edit)
Description Takanori MATSUURA 2005-01-07 05:33:22 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a6) Gecko/20050107 Fedora/1.0-2005010612_trunk

Description of problem:
Because tk-8.4.7 (and 8.4.9) don't have multiple-package-path mechanism like TCL_PACKAGE_PATH in tcl, some programs that needs tk cannot detect tk.tcl and they cannot run.

So if FC likes to set TK_PACKAGES to %{datadir}/%{name}%{majorver}, pkgInfo.tcl should be also installed to %{datadir}/%{name}%{majorver} and make symbolic link from %{libdir}/%{name}%{majorver} to %{datadir}/%{name}%{majorver}.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.install tk
2.install other program (eg. blt)
3.bltwish cannot detect tk.tcl
  

Actual Results:  In the case of bltwish, the following error occurs.

$ bltwish
Application initialization failed: Can't find a usable tk.tcl in the following directories:
    /usr/lib/tk8.4 /usr/lib/tk8.4 /lib/tk8.4 /usr/library /library /tk8.4.7/library /tk8.4.7/library



This probably means that tk wasn't installed properly.


Expected Results:  run without error

Additional info:
Comment 1 Takanori MATSUURA 2005-01-07 05:35:20 EST
Created attachment 109458 [details]
patch to fix this bug
Comment 2 Jens Petersen 2005-03-09 08:58:59 EST
blt in Fedora Extras seems to work fine:

# yum install blt
$ wish
% package require BLT
2.4
% 

This is on a x86_64 box btw.
It is basically because pkgIndex.tcl depends on the library
that it is under libdir for multilib to work ok.
Therefore I am not keen to move it to under datadir.

It might be better to ask upstream if they have some suggestion
how to improve the situation now or in the future. :)
Comment 3 Takanori MATSUURA 2005-03-29 19:55:37 EST
blt in Fedora Extras works fine because bltwish is not installed.
But this is not non-standard packaging.
I think my package is better.
http://my.reset.jp/~t-matsuu/install-memo/fc/blt.html

At the Bug Tracker at TK sourceforge site, someone said that Red Hat delivers
broken install. So This bug build be fixed or we should install with standard
manner.
https://sourceforge.net/tracker/?func=detail&atid=112997&aid=1171762&group_id=12997
Comment 4 Jens Petersen 2005-04-03 23:50:24 EDT
Ok, could you please open a bug against Fedora Extras blt to get it packaged
probably too.

Do you have a better solution to the tk problem that is multilib
(ie lib/lib64) friendly?
Comment 5 Takanori MATSUURA 2005-04-04 04:56:28 EDT
Packager of BLT in Fedora Extras said that he doesn't will to maintain as I wish.
https://bugzilla.fedora.us/show_bug.cgi?id=1646

If he has no disposition in maintainance, and Fedora Extras Staff accept me,
I'll maintain it.
Comment 6 Jens Petersen 2005-04-04 09:32:37 EDT
Oh, sorry for not being clear - bugzilla.fedora.us is now obsolete:
please use the "Fedora Extras" product in bugzilla.redhat.com for Extras
packages.

Though I tend to agree with him that with modern tcl/tk the trend seems to be
not to use separate commands for extensions, but just require
the package from the tclsh or wish. :)
Comment 7 Jens Petersen 2005-10-03 03:46:24 EDT
Re-assigning to blt owner for good measure.
Comment 8 Jean-Luc Fontaine 2005-10-03 07:03:41 EDT
As Jens mentioned before, "package require BLT" works just fine.
I can only reiterate:
"Command files are not required as BLT is a package that can be loaded using the
recommended 'package require' command.
Header files and static libraries, if needed at all (do you actually use them in
a C application?) should go in a new blt-devel rpm, which I do not have time or
the will to maintain."
Unless I misunderstood something and bltwish is specifically needed by another
package in Fedora, Tk certainly being installed properly, I am closing this bug.
Note that even wish itself will eventually disappear as "package require Tk"
already works from tclsh, code that the current version of moodss, for example,
uses. 

Note You need to log in before you can comment on or make changes to this bug.