This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 144461 - glib enables export-dynamic in pkg-config
glib enables export-dynamic in pkg-config
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: glib2 (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brian Stein
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-07 06:44 EST by Brian Stein
Modified: 2013-03-01 00:14 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-19 09:54:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Arjan van de Ven 2005-01-07 06:44:01 EST
Description of problem:

# pkg-config --libs gtk+-2.0
-Wl,--export-dynamic -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0
-lgdk_pixbuf-2.0 -lm -lpangoxft-1.0 -lpangox-1.0 -lpango-1.0
-lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0

this --export-dynamic is caused by
/usr/lib64/pkgconfig/gmodule-2.0.pc

the ripple-through is that most of our desktop is using
export-dynamic, causing lots of load time overhead and disk usage
Comment 1 Matthias Clasen 2005-01-07 09:50:07 EST
This has been fixed upstream in glib 2.6 by introducing
gmodule-no-export-2.0.pc, and using it at least in pango and gtk.

Note You need to log in before you can comment on or make changes to this bug.