Due to a recent update on Javascript code a full page refresh on your browser might be needed.
Bug 1444737 - qtermwidget doesn't properly obsolete qtermwidget-qt5
Summary: qtermwidget doesn't properly obsolete qtermwidget-qt5
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: qtermwidget
Version: 26
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Christian Dersch
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-24 07:31 UTC by Karel Volný
Modified: 2017-04-30 00:18 UTC (History)
4 users (show)

Fixed In Version: qtermwidget-0.7.1-2.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-30 00:18:27 UTC
Type: Bug


Attachments (Terms of Use)

Description Karel Volný 2017-04-24 07:31:31 UTC
Description of problem:
Trying to upgrade qterminal, it pulls qtermwidget package. However, the previous version pulled qtermwidget-qt5 and this collides.

Version-Release number of selected component (if applicable):
qtermwidget-0.7.1-1.fc26

How reproducible:
always

Steps to Reproduce:
1. dnf upgrade https://kojipkgs.fedoraproject.org//packages/qterminal/0.7.1/2.fc26/x86_64/qterminal-0.7.1-2.fc26.x86_64.rpm

Actual results:
Last metadata expiration check: 0:00:27 ago on Mon Apr 24 09:27:07 2017 CEST.
Dependencies resolved.
============================================================================================================================================================================================================================================================================================================================
 Package                                                                      Arch                                                                    Version                                                                        Repository                                                                        Size
============================================================================================================================================================================================================================================================================================================================
Upgrading:
 qterminal                                                                    x86_64                                                                  0.7.1-2.fc26                                                                   @commandline                                                                     150 k
Installing dependencies:
 qtermwidget                                                                  x86_64                                                                  0.7.1-1.fc26                                                                   updates-testing                                                                  219 k

Transaction Summary
============================================================================================================================================================================================================================================================================================================================
Install  1 Package
Upgrade  1 Package

Total size: 369 k
Is this ok [y/N]: y
Downloading Packages:
[SKIPPED] qtermwidget-0.7.1-1.fc26.x86_64.rpm: Already downloaded                                                                                                                                                                                                                                                          
Running transaction check
Transaction check succeeded.
Running transaction test
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Transaction check error:
  file /usr/lib64/libqtermwidget5.so.0 from install of qtermwidget-0.7.1-1.fc26.x86_64 conflicts with file from package qtermwidget-qt5-0.6.0-5.fc26.x86_64

Error Summary
-------------

Expected results:
no such error -
qtermwidget-0.7.1 provides qtermwidget-qt5 and obsoletes qtermwidget-qt5 < 0.7.0

Additional info:

Comment 1 Christian Dersch 2017-04-24 07:34:20 UTC
Already fixed with qtermwidget-0.7.1-2.fc26: https://bodhi.fedoraproject.org/updates/FEDORA-2017-ec98e192d4

I made a small mistake in first build...

Comment 2 Fedora Update System 2017-04-24 07:35:07 UTC
lxqt-l10n-0.11.2-6.fc26 qt-virt-manager-0.42.67-3.fc26 qterminal-0.7.1-2.fc26 qtermwidget-0.7.1-2.fc26 qtermwidget-qt4-0.6.0-2.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-ec98e192d4

Comment 3 Karel Volný 2017-04-24 10:24:49 UTC
cool, thanks

for some reason I've missed this qtermwidget build while I have found the newer (-2) qterminal ... I see it was submitted today, but after I have looked, probably some sync issue? - never mind

Comment 4 Christian Dersch 2017-04-24 10:33:53 UTC
Yes, I wanted to get new qtermwidget build in earlier, was a bit affected by the outage on Friday/Saturday.

Comment 5 Fedora Update System 2017-04-25 21:27:06 UTC
lxqt-l10n-0.11.2-6.fc26, qt-virt-manager-0.42.67-3.fc26, qterminal-0.7.1-2.fc26, qtermwidget-0.7.1-2.fc26, qtermwidget-qt4-0.6.0-2.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-ec98e192d4

Comment 6 Fedora Update System 2017-04-30 00:18:27 UTC
lxqt-l10n-0.11.2-6.fc26, qt-virt-manager-0.42.67-3.fc26, qterminal-0.7.1-2.fc26, qtermwidget-0.7.1-2.fc26, qtermwidget-qt4-0.6.0-2.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.