Bug 144476 - X segfaults randomly and fails to restore display and keyboard
X segfaults randomly and fails to restore display and keyboard
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
: Triaged
Depends On:
Blocks: FC4Target
  Show dependency treegraph
 
Reported: 2005-01-07 09:51 EST by Haakon Riiser
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-01 06:08:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X configuration (2.86 KB, text/plain)
2005-01-07 09:52 EST, Haakon Riiser
no flags Details
X log after crash (41.29 KB, text/plain)
2005-02-25 09:04 EST, Haakon Riiser
no flags Details

  None (edit)
Description Haakon Riiser 2005-01-07 09:51:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041217

Description of problem:
The X server in Fedora Core 3 crashes (signal 11) at random.
The last two crashes happened while I was using the Mozilla
web browser, but I don't think this is Mozilla's fault since
/var/log/Xorg.0.log says that the X server segfaulted.  After the
X server crashes, I have to log into my computer by remote to do
a clean reboot, since the console and keyboard is not restored
when X crashes.  It looks exactly like my computer froze, except
that I can still log in by network.

It looks like this bug only occurs while I'm actively using X,
since I have not seen it crash during weekends and other times
when I'm aways.  (X is, of course, still running.)  I has crashed
two times within a few hours today, and before the last crash
I even tried removing Load "dri" and Load "glx" from xorg.conf,
but that didn't help -- it still crashed. :-(

I never saw this in Fedora Core 1 (upgraded directly from FC1 to
FC3), so I'm sure it's a software bug.

  .--------------------.
  | Installed software |
  '--------------------'
  kernel-2.6.9-1.681_FC3
  xorg-x11-6.8.1-12.FC3.21
  glibc-2.3.4-2.fc3

  .------------------.
  | Hardware (lspci) |
  '------------------'
  00:00.0 Host bridge: Intel Corp. 82850 850 (Tehama) Chipset Host
Bridge (MCH) (rev 02)
  00:01.0 PCI bridge: Intel Corp. 82850 850 (Tehama) Chipset AGP
Bridge (rev 02)
  00:1e.0 PCI bridge: Intel Corp. 82801 PCI Bridge (rev 02)
  00:1f.0 ISA bridge: Intel Corp. 82801BA ISA Bridge (LPC) (rev 02)
  00:1f.1 IDE interface: Intel Corp. 82801BA IDE U100 (rev 02)
  00:1f.2 USB Controller: Intel Corp. 82801BA/BAM USB (Hub #1) (rev 02)
  00:1f.3 SMBus: Intel Corp. 82801BA/BAM SMBus (rev 02)
  00:1f.4 USB Controller: Intel Corp. 82801BA/BAM USB (Hub #2) (rev 02)
  01:00.0 VGA compatible controller: ATI Technologies Inc Radeon RV100
QY [Radeon 7000/VE]
  02:07.0 Ethernet controller: 3Com Corporation 3c905B 100BaseTX
[Cyclone] (rev 30)
  02:09.0 Multimedia audio controller: Ensoniq 5880 AudioPCI (rev 02)
  02:0a.0 USB Controller: NEC Corporation USB (rev 43)
  02:0a.1 USB Controller: NEC Corporation USB (rev 43)
  02:0a.2 USB Controller: NEC Corporation USB 2.0 (rev 04)

Version-Release number of selected component (if applicable):
xorg-x11-6.8.1-12.FC3.21

How reproducible:
Sometimes

Steps to Reproduce:
1. See description
2.
3.
    

Additional info:
Comment 1 Haakon Riiser 2005-01-07 09:52:36 EST
Created attachment 109467 [details]
X configuration
Comment 3 Mike A. Harris 2005-01-31 20:08:10 EST
Please make sure your system is upgraded with all of the current
Fedora Core 3 updates, and rebooted into the current FC3 kernel.

If this problem still occurs with a fully updated FC3 system,
please upgrade to the xorg-x11 from rawhide (fedora devel), which
is 6.8.1.903-2 at the time of this writing, and is slated to be
released for FC3 once xorg 6.8.2 is finalized in a week or so.

If you can still reproduce the problem after updating to the
rawhide xorg-x11, please attach your X server log, X config file,
and /var/log/messages from a failed session, to the bug report as
individual uncompressed file attachments.

Thanks in advance.
Comment 4 Mike A. Harris 2005-01-31 20:09:28 EST
Setting status to "NEEDINFO", and awaiting status update from
reporter in response to comment #3.
Comment 5 Haakon Riiser 2005-02-01 05:39:30 EST
I have regularly updated FC3, and haven't seen this bug in a while. 
It has probably been fixed, but I can't be 100% sure since I could
never consistently reproduce it.  Close it if you want; I can always
reopen it if the problem reappears.
Comment 6 Mike A. Harris 2005-02-01 06:08:45 EST
Ok, setting status to "RAWHIDE".  If the problem persists in
a fully updated FC3, including kernel for anyone, please
follow the request in comment #3 above prior to reopening
the bug report.

Thanks.

Comment 7 Haakon Riiser 2005-02-25 09:04:20 EST
Created attachment 111422 [details]
X log after crash

The server crashed again yesterday with the attached log.
At that time I was running a fully updated FC3, but the running
kernel was 2.6.10-1.760_FC3 since I hadn't yet rebooted into
2.6.10-1.766_FC3.  I am not able to reproduce this bug in any
way, it just happens from time to time.  I don't think the
log provides any useful information, but at least now you'll
/know/ that it doesn't. :-)

Note You need to log in before you can comment on or make changes to this bug.