Bug 144480 - Kernel 1069: Kernel panic on boot - buffered_rmqueue, __alloc_pages
Kernel 1069: Kernel panic on boot - buffered_rmqueue, __alloc_pages
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-07 11:06 EST by Ivan Gyurdiev
Modified: 2015-01-04 17:15 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-11 16:11:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivan Gyurdiev 2005-01-07 11:06:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041228 Firefox/1.0 Fedora/1.0-8

Description of problem:
Oops: 0002 [ #1 ] 
DEBUG_PAGEALLOC
Modules Linked in:
CPU: 0
EIP: 0060:[<C014105F>] Not tainted VLI
EFLAGS: 00010246 (2.6.10-1.1069_FC4)
EIP is at buffered_rmqueue + 0x1ff/0x244
eax: 00000000 ebx: c13fd220 ecx: 00000400 edx: 00000007
.... 
Process Swapper (pid: 0, threadinfo = c03ab000 task=c034fc20)
Stack: dfe91000 00000000 c13fd220 00000246 00080d0
....
Call Trace:
[ <c01411e1>] __alloc_pages + 0xae/0x295
[ <c0141410>] get_zeroed_page + 0x24/0x30
[ ..... ] pidmap_init + 0xb/0x36
[ ..... ] start_kernel + 0x110/0x16c 

<0> Kernel panic - not syncing: Attempted to kill the idle task

Kernel 1063 works fine

Version-Release number of selected component (if applicable):
kernel-2.6.10-1.1069_FC4

How reproducible:
Always

Steps to Reproduce:
1. Boot Fedora    

Additional info:
Comment 1 MASAO TAKAHASHI 2005-01-07 18:52:26 EST
I met just the same symptom.

1. ENVIRONMENT
   kernel: 2.6.10-1.1069_FC4, 2.6.10-1.1070_FC4
   CPU : Pentium4 2.66GHz
   CHIPSET : intel 82865G
   MEMORY : 512MB
   HDD : ATA 40GB

2. SYMPTOM
   Just same as this symptom. A Oops is occured on boot time.
   But, kernel-2.6.10-1.1053_FC4 and kernel-2.6.10-bk8 are OK.
 
Comment 2 Ivan Gyurdiev 2005-01-08 13:04:46 EST
Cannot reproduce with kernel 1074.
Comment 3 Dave Jones 2005-01-08 13:49:08 EST
leave this open until I figure out *why* this happens.

It was fixed by dropping the addition of GFP_ZERO. This patch is
likely to spawn a whole bunch of users using it to obtain zeroed
memory, so long-term this isn't a solution.  Upstream are looking at
this issue as well as its not fedora-specific.
Comment 4 Ivan Gyurdiev 2005-01-08 14:15:35 EST
By the way while kernel 1074 does boot, it doesn't work well at all.
Evolution starts the first time with it, and then locks up 
every time after. Furthermore the system froze within 10 mins of
using it. Should I investigate further and file more bugzillas?
Kernel 1063 works fine for me.


Comment 5 Dave Jones 2005-01-08 14:21:23 EST
no, I know whats causing that too. That's an unrelated issue.
(incompatability between CONFIG_PAGEALLOC and the periodic-slab-checker)
Comment 6 Ivan Gyurdiev 2005-01-11 13:28:16 EST
Kernel 1075 with the slab-checker fix did not
correct the Evolution problem.

However kernel 1076 boots, and fixes evolution too.

Comment 7 Dave Jones 2005-01-11 16:11:13 EST
fixed upstream now, and in the rebased update kernels in rawhide.

Note You need to log in before you can comment on or make changes to this bug.