Bug 1444829 - Failing to start the volume with ignore_volume_error doesn't stop gdeploy configuration
Summary: Failing to start the volume with ignore_volume_error doesn't stop gdeploy con...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gdeploy
Version: rhgs-3.2
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: RHGS 3.3.0
Assignee: Sachidananda Urs
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On:
Blocks: Gluster-HC-3 1417151 RHHI-1.1-Approved-Backlog-BZs
TreeView+ depends on / blocked
 
Reported: 2017-04-24 11:51 UTC by SATHEESARAN
Modified: 2017-09-21 04:49 UTC (History)
5 users (show)

Fixed In Version: gdeploy-2.0.2-5
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-21 04:49:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2777 normal SHIPPED_LIVE gdeploy bug fix and enhancement update for RHEL7 2017-09-21 08:23:08 UTC

Description SATHEESARAN 2017-04-24 11:51:36 UTC
Description of problem:
-----------------------
With RHGS 3.2.0, gdeploy ( gdeploy-2.0.1-11 ) introduced 'ignore_volume_errors' which force gdeploy to halt the configuration, when encountered with volume errors.

But when a volume fails to start, due to various reasons, gdeploy doesn't ignore that error and ignores it.

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
gdeploy-2.0.2-3.el7rhgs ( RHGS 3.3.0 interim )
gdeploy-2.0.1-11.el7rhgs ( RHGS 3.2.0 )

How reproducible:
-----------------
Always

Steps to Reproduce:
-------------------
1. Try to start the non-existent volume with gdeploy

Actual results:
---------------
With ignore_volume_errors=no in place, the volume start operation should **not** ignore the failure and stop execution.

Expected results:
-----------------
With ignore_volume_errors=no in place, the volume start operation should not ignore the error

Additional info:
----------------
[hosts]
host1

[volume]
action=start
volname=vol1
ignore_volume_errors=no

[shell]
action=execute
command=echo 'gdeploy doesn't halt' > /home/error

<snip>
TASK [Starts a volume] *********************************************************
fatal: [10.70.37.107]: FAILED! => {"changed": false, "failed": true, "msg": "volume start: vol1: failed: Volume vol1 does not exist\n", "rc": 1}
...ignoring
</snip>

Comment 1 Sachidananda Urs 2017-05-04 10:36:15 UTC
Commit: https://github.com/gluster/gdeploy/commit/683f0597b59 fixes the issue.

Comment 4 SATHEESARAN 2017-06-19 19:25:25 UTC
Tested with gdeploy-2.0.2-10.el7rhgs

When non-existent volume is tried to be started with gdeploy config file, with the following conf:

[volume]
volname=nonexistingvolume
action=start
ignore_volume_errors=no

gdeploy execution stops as the volume is not actually existing

Comment 6 errata-xmlrpc 2017-09-21 04:49:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2777


Note You need to log in before you can comment on or make changes to this bug.