Bug 1444830 - Error getting update information
Summary: Error getting update information
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnfdaemon
Version: 26
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Björn 'besser82' Esser
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1444825
TreeView+ depends on / blocked
 
Reported: 2017-04-24 11:54 UTC by Christian Stadelmann
Modified: 2017-05-06 17:10 UTC (History)
6 users (show)

Fixed In Version: dnfdaemon-0.3.17-2.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-06 17:10:30 UTC
Type: Bug


Attachments (Terms of Use)

Description Christian Stadelmann 2017-04-24 11:54:07 UTC
Description of problem:
Every time I get the update information through yumex-dnf or dnfdragora, dnfdaemon gives a traceback (see below).

Version-Release number of selected component (if applicable):
dnfdaemon-0.3.17-1.fc26.noarch

How reproducible:
always

Steps to Reproduce:
1. open yumex-dnf or dnfdragora
2. display update information for any package

Actual results:
Crash

Expected results:
no crash

Additional info:
This causes a crasher in dnfdragora, see bug #1444825.

Traceback:
g-io-error-quark: GDBus.Error:org.freedesktop.DBus.Python.AttributeError: Traceback (most recent call last):
  File "/usr/lib64/python3.6/site-packages/dbus/service.py", line 707, in _message_cb
    retval = candidate_method(self, *args, **keywords)
  File "/usr/lib/python3.6/site-packages/dnfdaemon/server/__init__.py", line 83, in newFunc
    rc = func(*args, **kwargs)
  File "/usr/share/dnfdaemon/dnfdaemon-system", line 273, in GetAttribute
    value = self.get_attribute(pkg_id, attr)
  File "/usr/lib/python3.6/site-packages/dnfdaemon/server/__init__.py", line 343, in get_attribute
    value = json.dumps(self._get_fake_attributes(po, attr))
  File "/usr/lib/python3.6/site-packages/dnfdaemon/server/__init__.py", line 909, in _get_fake_attributes
    return self._get_update_info(po)
  File "/usr/lib/python3.6/site-packages/dnfdaemon/server/__init__.py", line 846, in _get_update_info
    value = updinfo.advisories_list()
  File "/usr/lib/python3.6/site-packages/dnfdaemon/server/backend.py", line 524, in advisories_list
    e[field] = getattr(adv, field)
AttributeError: '_hawkey.Advisory' object has no attribute 'filenames'
 (36)

Comment 1 Christian Stadelmann 2017-04-24 11:57:57 UTC
The crasher is caused by an api deprecation: https://hawkey.readthedocs.io/en/latest/changes.html#deprecated-hawkey-advisory-filenames

Comment 2 Angelo Naselli 2017-05-01 19:58:58 UTC
Could you please test this patch?
https://github.com/anaselli/dnf-daemon/commit/3e5d82ddee1512ebbb8cf2779a887bc56ce526c3
filenames has been removed from libdnf.

Comment 3 Christian Stadelmann 2017-05-01 20:13:41 UTC
(In reply to Angelo Naselli from comment #2)
> Could you please test this patch?
> https://github.com/anaselli/dnf-daemon/commit/
> 3e5d82ddee1512ebbb8cf2779a887bc56ce526c3
> filenames has been removed from libdnf.

That works around the crasher, yes.

Comment 4 Björn 'besser82' Esser 2017-05-01 20:25:42 UTC
I just applied the patch to dnfdaemon; new packages are currently building.  Update will be on it's way soon.

Comment 5 Fedora Update System 2017-05-01 20:27:11 UTC
dnfdaemon-0.3.17-2.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-f97dcd8bd6

Comment 6 Fedora Update System 2017-05-03 17:19:01 UTC
dnfdaemon-0.3.17-2.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-f97dcd8bd6

Comment 7 Fedora Update System 2017-05-04 22:04:18 UTC
dnfdaemon-0.3.17-2.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-f97dcd8bd6

Comment 8 Fedora Update System 2017-05-06 17:10:30 UTC
dnfdaemon-0.3.17-2.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.