Bug 1444887 - Wrong connection edited in UI when a device activated in initramfs (boot options) is reconfigured by kickstart without reactivation [NEEDINFO]
Summary: Wrong connection edited in UI when a device activated in initramfs (boot opti...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda
Version: 7.3
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: rc
: 7.4
Assignee: Radek Vykydal
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks: 1299988
TreeView+ depends on / blocked
 
Reported: 2017-04-24 13:36 UTC by Radek Vykydal
Modified: 2017-08-01 08:55 UTC (History)
7 users (show)

Fixed In Version: anaconda-21.48.22.113-1
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2017-08-01 08:55:41 UTC
Target Upstream Version:
pjanda: needinfo? (mkolman)


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2293 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2017-08-01 12:39:44 UTC
IBM Linux Technology Center 153653 None None None 2017-04-25 09:42:31 UTC
Red Hat Bugzilla 1433891 None None None Never
Red Hat Bugzilla 1439220 None None None Never

Internal Links: 1433891 1439220

Description Radek Vykydal 2017-04-24 13:36:19 UTC
Description of problem:

If a device activated in initramfs is reconfigured via kickstart without being activated in installer (based on network --activate / --on-activate options), the connection exposed in GUI is not the one corresponding to persistent (ifcfg / target system) configuration but a connection created for initramfs device config.
If it is changed in UI, it is saved as another persistent configuration ifcfg-<NIC>-1, eg ifcfg-ens3-1.

Version-Release number of selected component (if applicable):
RHEL 7.3 GA
RHEL-7.4-20170421.n.1

How reproducible:

Alway, but depends on order of connections for a device returned by NM which is may not be determininstic.


Steps to Reproduce:

1. Run installation requiring network in initramfs (eg pxe installation) with ip=ens3:dhcp (or no ip= specified which defaults to dhcp)

Kickstart file contains reconfiguration of the device without activation in installer:

network --device=ens3 --bootproto=static --ip=10.34.102.233 --gateway=10.34.102.254 --netmask=255.255.255.0 --activate --nameserver=10.34.39.2 --no-activate


2a. GUI: Edit ens3 device ipv4 network configuration in network spoke - dhcp is preset (because we are not editing the ifcfg connection, but in-memory NM connection).

2b. TUI: Edit ens3 connection, values for the ifcfg connection (static ipv4 config) are displayed.

3. Modify and save the configuration.

Actual results:

For both GUI and TUI, additional ifcfg-ens3-1 ifcfg file is created for the configuration modified in UI, instead of changing ifcfg-ens3 which is keeping the kickstart configuration.

Expected results:

In GUI, ifcfg connection is displayed.
Both in GUI and TUI, the persistent connetion (ifcfg-ens3) is updated with values configured from UI.

Additional info:

A kickstart test failing due to the same root cause:
https://github.com/rhinstaller/kickstart-tests/blob/master/network-noipv4-httpks.ks.in

Comment 2 Radek Vykydal 2017-04-25 11:04:04 UTC
https://github.com/rhinstaller/anaconda/pull/1038

Comment 4 Petr Janda 2017-04-28 06:53:47 UTC
accidentally removed qa_ack+ setting it back

Comment 6 Fedora Update System 2017-06-13 16:25:06 UTC
anaconda-26.21.8-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-f8d6a1f05a

Comment 8 Fedora Update System 2017-06-15 13:57:42 UTC
anaconda-26.21.8-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-f8d6a1f05a

Comment 10 Fedora Update System 2017-06-16 12:16:57 UTC
anaconda-26.21.9-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-f8d6a1f05a

Comment 11 Fedora Update System 2017-06-16 22:22:52 UTC
anaconda-26.21.9-1.fc26, pykickstart-2.35-1.fc26, python-blivet-2.1.9-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-f8d6a1f05a

Comment 12 errata-xmlrpc 2017-08-01 08:55:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2293


Note You need to log in before you can comment on or make changes to this bug.