Bug 1444950
| Summary: | [containers] Downstream Docker images with overcloud services don't contain bash shell | ||
|---|---|---|---|
| Product: | Red Hat OpenStack | Reporter: | Artem Hrechanychenko <ahrechan> |
| Component: | openstack-containers | Assignee: | Jon Schlueter <jschluet> |
| Status: | CLOSED ERRATA | QA Contact: | Omri Hochman <ohochman> |
| Severity: | high | Docs Contact: | Andrew Burden <aburden> |
| Priority: | high | ||
| Version: | 12.0 (Pike) | CC: | ahrechan, jschluet, lruzicka |
| Target Milestone: | Upstream M2 | Keywords: | Triaged |
| Target Release: | 12.0 (Pike) | ||
| Hardware: | All | ||
| OS: | Linux | ||
| Whiteboard: | |||
| Fixed In Version: | openstack-memcached-docker-12.0-20170425.1 | Doc Type: | If docs needed, set a value |
| Doc Text: | Story Points: | --- | |
| Clone Of: | Environment: | ||
| Last Closed: | 2017-12-13 19:14:33 UTC | Type: | Bug |
| Regression: | --- | Mount Type: | --- |
| Documentation: | --- | CRM: | |
| Verified Versions: | Category: | --- | |
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |
| Cloudforms Team: | --- | Target Upstream Version: | |
| Embargoed: | |||
|
Description
Artem Hrechanychenko
2017-04-24 15:24:26 UTC
what does docker ps -a show for memcached container (In reply to Jon Schlueter from comment #1) > what does docker ps -a show for memcached container [heat-admin@overcloud-controller-0 ~]$ sudo docker ps -a CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES e96e70875a0d 192.168.24.1:8787/rhosp12/2017-04-13.1:openstack-memcached-docker "/bin/bash -c 'source" 13 hours ago Created memcached [heat-admin@overcloud-controller-0 ~]$ sudo docker exec -it memcached /bin/bash Error response from daemon: Container e96e70875a0d5636235609998929fe4ef4568d3fee9e4743d422873e14f3be23 is not running after rebuilding and fixing a related issue I think the containers look better and I was able to run docker run -it --rm <memcached image> bash and it provided a shell before rebuild it was failing as described above. docker-registry.engineering.redhat.com/rhosp12/openstack-memcached-docker:2017-04-13.1-1 unable to reproduce: OpenStack-12.0-RHEL-7 Puddle: 2017-10-24.3 Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. For information on the advisory, and where to find the updated files, follow the link below. If the solution does not work for you, open a new bug report. https://access.redhat.com/errata/RHEA-2017:3457 |