Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 1444950

Summary: [containers] Downstream Docker images with overcloud services don't contain bash shell
Product: Red Hat OpenStack Reporter: Artem Hrechanychenko <ahrechan>
Component: openstack-containersAssignee: Jon Schlueter <jschluet>
Status: CLOSED ERRATA QA Contact: Omri Hochman <ohochman>
Severity: high Docs Contact: Andrew Burden <aburden>
Priority: high    
Version: 12.0 (Pike)CC: ahrechan, jschluet, lruzicka
Target Milestone: Upstream M2Keywords: Triaged
Target Release: 12.0 (Pike)   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: openstack-memcached-docker-12.0-20170425.1 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-12-13 19:14:33 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Artem Hrechanychenko 2017-04-24 15:24:26 UTC
Description of problem:
I tried to install RHOSP12 with containerized overcloud services
and received next issue:

"/usr/bin/docker-current: Error response from daemon: invalid header field value "oci runtime error: container_linux.go:247: starting container process caused \"exec: \\\"/bin/bash\\\": stat /bin/bash: no such file or directory\"\n"."


Version-Release number of selected component (if applicable):
RHOSP 12

How reproducible:
Always

Steps to Reproduce:

 1) #infrared virsh -v --host-address $HOST --host-key ~/.ssh/id_rsa --topology-nodes undercloud:1,controller:1,compute:1 -e override.controller.cpu=8 -e override.controller.memory=32768 -e override.undercloud.disks.disk1.size=100G

2) # infrared tripleo-undercloud --version 12 --images-task=rpm

3) # infrared tripleo-overcloud -v --introspect yes --tagging yes --post no --deployment-files virt --version 12 --deploy no

Pre-deployment steps for containerized overcloud
4) http://etherpad.corp.redhat.com/testing-osp12-containers


command to deploy overcloud:
 
#5) openstack overcloud deploy --templates /usr/share/openstack-tripleo-heat-templates --libvirt-type kvm  --control-scale 1 --control-flavor controller  --compute-scale 1 --compute-flavor compute -e /usr/share/openstack-tripleo-heat-templates/environments/docker.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/docker-osp12.yaml --log-file overcloud_deployment_0.log


Actual results:
Stack deployment failed

Expected results:
Overcloud deployed

Additional info:
#openstack stack failures list overcloud --long:
http://pastebin.test.redhat.com/477719

[heat-admin@overcloud-controller-0 ~]$ sudo docker ps -a
CONTAINER ID        IMAGE                                                               COMMAND                  CREATED             STATUS              PORTS               NAMES
e96e70875a0d        192.168.24.1:8787/rhosp12/2017-04-13.1:openstack-memcached-docker   "/bin/bash -c 'source"   13 hours ago        Created                                 memcached

[heat-admin@overcloud-controller-0 ~]$ sudo docker exec -it memcached /bin/bash
Error response from daemon: Container e96e70875a0d5636235609998929fe4ef4568d3fee9e4743d422873e14f3be23 is not running
[heat-admin@overcloud-controller-0 ~]$ sudo docker restart memcached
Error response from daemon: Cannot restart container memcached: invalid header field value "oci runtime error: container_linux.go:247: starting container process caused \"exec: \\\"/bin/bash\\\": stat /bin/bash: no such file or directory\"\n"

Comment 1 Jon Schlueter 2017-04-24 19:52:49 UTC
what does docker ps -a show for memcached container

Comment 2 Artem Hrechanychenko 2017-04-24 20:32:01 UTC
(In reply to Jon Schlueter from comment #1)
> what does docker ps -a show for memcached container

[heat-admin@overcloud-controller-0 ~]$ sudo docker ps -a
CONTAINER ID        IMAGE                                                               COMMAND                  CREATED             STATUS              PORTS               NAMES
e96e70875a0d        192.168.24.1:8787/rhosp12/2017-04-13.1:openstack-memcached-docker   "/bin/bash -c 'source"   13 hours ago        Created                                 memcached

[heat-admin@overcloud-controller-0 ~]$ sudo docker exec -it memcached /bin/bash
Error response from daemon: Container e96e70875a0d5636235609998929fe4ef4568d3fee9e4743d422873e14f3be23 is not running

Comment 3 Jon Schlueter 2017-04-26 18:30:57 UTC
after rebuilding and fixing a related issue I think the containers look better and I was able to run docker run -it --rm <memcached image> bash 

and it provided a shell before rebuild it was failing as described above.

docker-registry.engineering.redhat.com/rhosp12/openstack-memcached-docker:2017-04-13.1-1

Comment 9 Omri Hochman 2017-10-26 20:07:53 UTC
unable to reproduce: OpenStack-12.0-RHEL-7 Puddle: 2017-10-24.3

Comment 13 errata-xmlrpc 2017-12-13 19:14:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3457