Bug 1444988 - Redis libexec shutdown script
Summary: Redis libexec shutdown script
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: redis
Version: epel7
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Nathan Scott
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-24 17:07 UTC by petrb
Modified: 2017-09-04 17:49 UTC (History)
6 users (show)

Fixed In Version: redis-3.2.10-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-04 17:49:30 UTC


Attachments (Terms of Use)
Redis-Shutdown proposed change (1.12 KB, application/x-shellscript)
2017-04-24 17:07 UTC, petrb
no flags Details

Description petrb 2017-04-24 17:07:52 UTC
Created attachment 1273658 [details]
Redis-Shutdown proposed change

Description of problem:

Consider the following scenario, you have redis listening only on unix socket but not on any port or interface.

The error from systemd was redis.service stopping timed out. Terminating. because it was trying to stop a redis on 127.0.0.1 and port 0 obviously, because redis was not running on port.

So i fixed the redis-shutdown wrapper, it now uses socket, if there is one, and behaves normally when there isnt one.

Proposed redis-shutdown with fix is in attachment

Version-Release number of selected component (if applicable):
3.2.8

How reproducible:
always

Steps to Reproduce:
1. make redis listen on port 0
2. start redis
3. stop redis

Actual results:
systemd was redis.service stopping timed out

Expected results:
restart redis service

Additional info:

Comment 1 Carl George 2017-07-28 19:18:21 UTC
I'm not involved with this package but I noticed that it appears to be fixed in rawhide with redis-3.2.9-1, even referencing this bug specifically.

- Fix a shutdown failure with Unix domain sockets (RHBZ #1444988)

https://src.fedoraproject.org/cgit/rpms/redis.git/commit/?id=4f1d5f156de46eb4dd7883bdaf512f6fc6e4a4d4

Now it's just a matter of backporting it to the epel7 branch.

Comment 2 Nathan Scott 2017-08-17 04:30:24 UTC
If anyone needs this fix, I've produced a COPR with a
fixed version (3.2.10 currently) for el6 and el7 here:
https://copr.fedorainfracloud.org/coprs/nathans/redis3/

Comment 3 Fedora Update System 2017-08-18 01:30:16 UTC
redis-3.2.10-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-07d2039ffa

Comment 4 Fedora Update System 2017-08-18 20:24:17 UTC
redis-3.2.10-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-07d2039ffa

Comment 5 Fedora Update System 2017-09-04 17:49:30 UTC
redis-3.2.10-2.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.