Bug 144504 - deleting share fails
deleting share fails
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-samba (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-07 15:40 EST by Phil Schaffner
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-12 11:53:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Phil Schaffner 2005-01-07 15:40:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.3)
Gecko/20041020

Description of problem:
Deleting a share in the GUI has no effect on the /etc/samba/smb.conf


Version-Release number of selected component (if applicable):
system-config-samba-1.2.25-0.fc3.1

How reproducible:
Always

Steps to Reproduce:
1. run system-config-samba
2. delete a share
3. exit
    

Actual Results:  Share is not removed, despite disappearing in the
GUI.  Reappears if GUI is run again.

Expected Results:  Deleted share should be removed from smb.conf


Additional info:

Only adding shares is mentioned in the documentation.  If the delete
is intentionally not implemented that should be documented and the
Delete button removed.
Comment 1 Nils Philippsen 2005-01-11 04:09:12 EST
Hmm, this works for me:

- added share [tmp] for /tmp -> was added to smb.conf
- deleted share [tmp] -> was removed from smb.conf

Do you have any python tracebacks etc. when running this from the
command line?
Comment 2 Phil Schaffner 2005-01-12 09:23:36 EST
From further testing, seems to delete shares added by the tool, but
not those pre-existing or added by editing smb.conf.  Example:

[root@radar0 samba]# mkdir /test
[root@radar0 samba]# chmod 777 /test

Added the following to smb.conf:

[Test]
        comment = ext3 test on radar0
        path = /test
        writeable = yes
        write list = prs
        printable = no

Verify that Samba sees the share:

[root@radar0 samba]# service smb restart
Shutting down SMB services:                                [  OK  ]
Shutting down NMB services:                                [  OK  ]
Starting SMB services:                                     [  OK  ]
Starting NMB services:                                     [  OK  ]
[root@radar0 samba]# smbclient -L radar0
Password:
Anonymous login successful
Domain=[RTG-FETD-SRB] OS=[Unix] Server=[Samba 3.0.10-1.fc3]

        Sharename       Type      Comment
        ---------       ----      -------
        tmp             Disk      Temporary file space
        Test            Disk      ext3 test on radar0
        VFAT            Disk      Formerly VFAT Interchange Partition
        Raid            Disk      ext3 raid on radar0
        RaidPub         Disk      Public directory on radar0
        RaidUser        Disk      /raid/share/[user] on radar0
        Old_Home        Disk      Read-Write Old Home
        Root            Disk      Sys Admin Files
        IPC$            IPC       IPC Service (Samba Server on Radar0)
        ADMIN$          IPC       IPC Service (Samba Server on Radar0)
        Beech           Printer   HP Color LaserJet 4600
        Eagle_C80       Printer   C80 on Eagle
        sycamore        Printer   sycamore
Anonymous login successful
Domain=[RTG-FETD-SRB] OS=[Unix] Server=[Samba 3.0.10-1.fc3]

        Server               Comment
        ---------            -------
        RADAR0               Samba Server on Radar0

        Workgroup            Master
        ---------            -------
        RTG-FETD-SRB
[root@radar0 samba]# service smb stop
Shutting down SMB services:                                [  OK  ]
Shutting down NMB services:                                [  OK  ]

Run the tool and delete the share:

[root@radar0 samba]# system-config-samba
/usr/share/system-config-samba/mainWindow.py:116: DeprecationWarning:
use gtk.UIManager
  item_fac = gtk.ItemFactory(gtk.MenuBar, "<main>", accel_group)
/usr/share/system-config-samba/mainWindow.py:141: DeprecationWarning:
  button = self.toolbar.insert_stock('gtk-add', _("Add a samba
share"), None, self.onNewButtonClicked, None, 0)
/usr/share/system-config-samba/mainWindow.py:146: DeprecationWarning:
  self.properties_button = self.toolbar.insert_stock('gtk-properties',
_("Edit the properties of the selected directory"), None,
self.onPropertiesButtonClicked, None, 1)
/usr/share/system-config-samba/mainWindow.py:151: DeprecationWarning:
  self.delete_button = self.toolbar.insert_stock('gtk-delete',
_("Delete the selected directory"), None, self.onDeleteButtonClicked,
None, 2)
/usr/share/system-config-samba/mainWindow.py:156: DeprecationWarning:
  self.toolbar.insert_stock('gtk-help', _("View help"), None,
self.onHelpClicked, None, 3)

Run again and see that it is still present:

[root@radar0 samba]# system-config-samba
/usr/share/system-config-samba/mainWindow.py:116: DeprecationWarning:
use gtk.UIManager
  item_fac = gtk.ItemFactory(gtk.MenuBar, "<main>", accel_group)
/usr/share/system-config-samba/mainWindow.py:141: DeprecationWarning:
  button = self.toolbar.insert_stock('gtk-add', _("Add a samba
share"), None, self.onNewButtonClicked, None, 0)
/usr/share/system-config-samba/mainWindow.py:146: DeprecationWarning:
  self.properties_button = self.toolbar.insert_stock('gtk-properties',
_("Edit the properties of the selected directory"), None,
self.onPropertiesButtonClicked, None, 1)
/usr/share/system-config-samba/mainWindow.py:151: DeprecationWarning:
  self.delete_button = self.toolbar.insert_stock('gtk-delete',
_("Delete the selected directory"), None, self.onDeleteButtonClicked,
None, 2)
/usr/share/system-config-samba/mainWindow.py:156: DeprecationWarning:
  self.toolbar.insert_stock('gtk-help', _("View help"), None,
self.onHelpClicked, None, 3)
[root@radar0 samba]#

Can't see much helpful.  Warnings are the same on the second session
where I did not attempt to delete the share.

Let me know if I can supply more information.


Comment 3 Nils Philippsen 2005-01-12 10:31:52 EST
The problem seems to be that your share name has upper case letters and that the
code dealing with that (due to share names being treated case-insensitive) has a
bug or two.
Comment 4 Nils Philippsen 2005-01-12 10:43:34 EST
fixed in CVS
Comment 5 Nils Philippsen 2005-01-12 11:53:58 EST
Fixed in system-config-samba-1.2.26-0.fc3.1 which should hit the mirrors soon.

Note You need to log in before you can comment on or make changes to this bug.