Bug 144508 - Use RPC instead of signal for doing CCS updates
Use RPC instead of signal for doing CCS updates
Status: CLOSED NEXTRELEASE
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: ccs (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Earl Brassow
Cluster QE
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-07 15:53 EST by Jonathan Earl Brassow
Modified: 2009-04-16 16:04 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-11 18:43:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Earl Brassow 2005-01-07 15:53:12 EST
Description of problem:

A signal is currently used to tell ccsd to update a config file.  This
has a number of limitations:
1. signals are asynchornous, making it hard to error results
2. Although I believe most issues have been worked out, signals can be
recieved at any time, making the code more complex because it has to
do various forms of locking to ensure that processing doesn't happen
while things are changing

The code complexities and various hacks to do meaningful error
reporting should be replaced by a more eligant solution.  That
solution involves ccs_tool taking an update file and sending it to
ccsd for processing.

Because a sizeable amount of code will have to be changed to
facilitate this, it may not be advisable to change the code so close
to a release.
Comment 1 Jonathan Earl Brassow 2005-01-11 18:43:57 EST
update now uses socket to communicate with ccsd to do updates rather
than signals.

Note You need to log in before you can comment on or make changes to this bug.