Bug 1445263 - Snapshot remains in locked status after async delete using api (only when using async)
Summary: Snapshot remains in locked status after async delete using api (only when usi...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.0.7
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ovirt-4.2.0
: ---
Assignee: Ala Hino
QA Contact: meital avital
URL:
Whiteboard:
Depends On: 1447050
Blocks: 1449750
TreeView+ depends on / blocked
 
Reported: 2017-04-25 11:50 UTC by nijin ashok
Modified: 2020-06-11 13:41 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
: 1447050 1449750 (view as bug list)
Environment:
Last Closed: 2018-05-15 17:42:49 UTC
oVirt Team: Storage
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3013701 0 None None None 2017-04-26 00:25:48 UTC
Red Hat Product Errata RHEA-2018:1488 0 None None None 2018-05-15 17:44:33 UTC
oVirt gerrit 76249 0 master MERGED async-command: Remove setting parent command 2017-05-08 14:05:34 UTC

Description nijin ashok 2017-04-25 11:50:29 UTC
Description of problem:

When deleting the snapshots live using api with async=True, the snapshot remains in locked status and is not removed. The images are merged in the vdsm side and is removed correctly. Also the images table is updated with the correct info. However the snapshot remains in the snapshot table in locked status.

Version-Release number of selected component (if applicable):

rhevm-4.0.6.3-0.1.el7ev.noarch

How reproducible:

100%

Steps to Reproduce:

Remove snapshot live on a VM with async=True using api

Actual results:

Snapshot is not removed correctly.

Expected results:

Snapshot delete should work fine.

Additional info:

Comment 3 Tal Nisan 2017-04-25 12:11:22 UTC
Nijin, does this reproduce without the "async=True"?

Comment 4 nijin ashok 2017-04-25 12:38:37 UTC
(In reply to Tal Nisan from comment #3)
> Nijin, does this reproduce without the "async=True"?

Nop, it only happens with "async=True" .

Comment 7 Lilach Zitnitski 2017-11-14 09:48:23 UTC
--------------------------------------
Tested with the following code:
----------------------------------------
ovirt-engine-4.2.0-0.0.master.20171112130303.git8bc889c.el7.centos.noarch
vdsm-4.20.6-62.gitd3023e4.el7.centos.x86_64

Tested with the following scenario:

Steps to Reproduce:
Remove snapshot live on a VM with async=True using api

Actual results:
Snapshot delete is working fine and snapshot is removed

Expected results:

Moving to VERIFIED!

Comment 11 errata-xmlrpc 2018-05-15 17:42:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:1488

Comment 12 Franta Kust 2019-05-16 13:09:04 UTC
BZ<2>Jira Resync


Note You need to log in before you can comment on or make changes to this bug.