Bug 144529 - rpmbuild from kernel-2.6.9-1.724_FC3.src.rpm fails
rpmbuild from kernel-2.6.9-1.724_FC3.src.rpm fails
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-07 17:20 EST by Joe Christy
Modified: 2015-01-04 17:15 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-12 13:28:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log from a failed rpmbuild (32.44 KB, text/plain)
2005-01-07 17:20 EST, Joe Christy
no flags Details

  None (edit)
Description Joe Christy 2005-01-07 17:20:41 EST
Description of problem:
One can't execute rpmbuild -bp with kernel-2.6.9-1.724_FC3.src.rpm.


Version-Release number of selected component (if applicable):
kernel-2.6.9-1.724_FC3.src.rpm

How reproducible:
Every time

Steps to Reproduce:
1. rpm -ivh kernel-2.6.9-1.724_FC3.src.rpm
2. rpmbuild -bp --target=i686 kernel-2.6.spec
3. Groan
  
Actual results:
rpmbuild dies running oldconfig over all the config files.
Specifically make ARCH=i386 nonint_oldconfig trys to assign many  nonexistent
symbols.

Expected results:
rpmbuild finishes

Additional info:
cf. attached build log
Comment 1 Joe Christy 2005-01-07 17:20:41 EST
Created attachment 109502 [details]
log from a failed rpmbuild
Comment 2 Dave Jones 2005-01-07 21:43:56 EST
it's complaining about the lack of CONFIG_MEGARAID_LEGACY. (The other warnings
are just informational, and won't cause any problems).

Why it's doing that I'm not sure, as it's definitly defined here...

configs/kernel-2.6.9-i586.config:CONFIG_MEGARAID_LEGACY=m
configs/kernel-2.6.9-i586-smp.config:CONFIG_MEGARAID_LEGACY=m
configs/kernel-2.6.9-i686.config:CONFIG_MEGARAID_LEGACY=m
configs/kernel-2.6.9-i686-hugemem.config:CONFIG_MEGARAID_LEGACY=m
configs/kernel-2.6.9-i686-smp.config:CONFIG_MEGARAID_LEGACY=m
configs/kernel-2.6.9-ia64.config:CONFIG_MEGARAID_LEGACY=m
configs/kernel-2.6.9-ppc64.config:CONFIG_MEGARAID_LEGACY=m
configs/kernel-2.6.9-ppc64iseries.config:CONFIG_MEGARAID_LEGACY=m
configs/kernel-2.6.9-ppc.config:CONFIG_MEGARAID_LEGACY=m
configs/kernel-2.6.9-x86_64.config:CONFIG_MEGARAID_LEGACY=m
configs/kernel-2.6.9-x86_64-smp.config:CONFIG_MEGARAID_LEGACY=m
Comment 3 Joe Christy 2005-01-12 12:11:23 EST
The problem no longer exists with kernel-2.6.10-1.737_FC3.src.rpm
Comment 4 Joe Christy 2005-01-12 12:21:45 EST
FWIW, I think the problem was simply in the packaging. After I submitted the
bug, I noticed that the spec file, towards the end of pre, was iterating
oldconfig over a list of directories that it had generated by reading from the
BUILD tree on disc. Unfortunately, there was a spurious i386 subdirectory that
sent rpmbuild off trying to config an i386 kernel, which hasn't been supported
for some time.

In any case, a) the rpmbuild failure nonetheless left me with the bits I needed
to (attempt to) build a custom kernel for my Pentium M laptop (which wouldn't
compile with the tweaks i wanted anyway), and b) the latest kernel src.rpm
doesn't suffer from the problem (and I built my custom kernel w/o problems).

Note You need to log in before you can comment on or make changes to this bug.