Bug 1445302 - partition on a FW RAID used as a PV is put into a list of filtered devices by blivet
Summary: partition on a FW RAID used as a PV is put into a list of filtered devices by...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-blivet
Version: 26
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vratislav Podzimek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:77186c3f2bbc1946267c0ff712b...
: 1445646 (view as bug list)
Depends On:
Blocks: F26BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2017-04-25 13:09 UTC by Petr Schindler
Modified: 2017-05-22 17:38 UTC (History)
13 users (show)

Fixed In Version: python-blivet-2.1.7-10.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-22 17:38:19 UTC


Attachments (Terms of Use)
File: anaconda-tb (400.98 KB, text/plain)
2017-04-25 13:09 UTC, Petr Schindler
no flags Details
File: environ (509 bytes, text/plain)
2017-04-25 13:09 UTC, Petr Schindler
no flags Details
File: journalctl (290.59 KB, text/plain)
2017-04-25 13:09 UTC, Petr Schindler
no flags Details
File: lsblk_output (5.66 KB, text/plain)
2017-04-25 13:09 UTC, Petr Schindler
no flags Details
File: nmcli_dev_list (2.42 KB, text/plain)
2017-04-25 13:09 UTC, Petr Schindler
no flags Details
File: os_info (518 bytes, text/plain)
2017-04-25 13:09 UTC, Petr Schindler
no flags Details
program.log (38.48 KB, text/plain)
2017-05-02 12:34 UTC, Petr Schindler
no flags Details
storage.log (216.88 KB, text/plain)
2017-05-02 12:35 UTC, Petr Schindler
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1445654 None None None Never

Internal Links: 1445654

Description Petr Schindler 2017-04-25 13:09:32 UTC
Description of problem:
It crashed when I clicked on Installation destination.

There is one firmware RAID5 disk. There is Fedora 26 (default partitioning) installed on that disk.

Version-Release number of selected component:
anaconda-core-26.21.3-1.fc26.x86_64

The following was filed automatically by anaconda:
anaconda 26.21.3-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python3.6/site-packages/gi/overrides/BlockDev.py", line 762, in wrapped
    raise transform[1](msg)
  File "/usr/lib/python3.6/site-packages/blivet/formats/lvmpv.py", line 163, in free
    pv_info = blockdev.lvm.pvinfo(self.device)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/blivet.py", line 754, in get_free_space
    elif hasattr(partition.format, "free"):
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 731, in _add_disk_overview
    free = self.storage.get_free_space(disks=[disk])[disk.name][0]
  File "/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 645, in refresh
    self._add_disk_overview(disk, self.local_disks_box)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 411, in _on_spoke_clicked
    spoke.refresh()
gi.overrides.BlockDev.LVMError: Process reported exit code 1280:   WARNING: Device for PV nIS1Xt-FAIE-7tei-T8yr-lj7e-DZQ2-vpS4iv not found or rejected by a filter.
  Failed to find device for physical volume "/dev/md/Volume0_0p3".
  WARNING: Device for PV nIS1Xt-FAIE-7tei-T8yr-lj7e-DZQ2-vpS4iv not found or rejected by a filter.
  WARNING: Couldn't find all devices for LV fedora/swap while checking used and assumed devices.
  WARNING: Couldn't find all devices for LV fedora/home while checking used and assumed devices.
  WARNING: Couldn't find all devices for LV fedora/root while checking used and assumed devices.


Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/libexec/system-python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.11.0-0.rc6.git0.1.fc26.x86_64
other involved packages: anaconda-gui-26.21.3-1.fc26.x86_64, python3-blivet-2.1.7-8.fc26.noarch, python3-blockdev-2.6-3.fc26.x86_64
product:        Fedora
release:        Fedora release 26 (Twenty Six)
type:           anaconda
version:        26

Potential duplicate: bug 1430039

Comment 1 Petr Schindler 2017-04-25 13:09:39 UTC
Created attachment 1273904 [details]
File: anaconda-tb

Comment 2 Petr Schindler 2017-04-25 13:09:40 UTC
Created attachment 1273905 [details]
File: environ

Comment 3 Petr Schindler 2017-04-25 13:09:43 UTC
Created attachment 1273906 [details]
File: journalctl

Comment 4 Petr Schindler 2017-04-25 13:09:45 UTC
Created attachment 1273907 [details]
File: lsblk_output

Comment 5 Petr Schindler 2017-04-25 13:09:47 UTC
Created attachment 1273908 [details]
File: nmcli_dev_list

Comment 6 Petr Schindler 2017-04-25 13:09:48 UTC
Created attachment 1273909 [details]
File: os_info

Comment 7 Petr Schindler 2017-04-25 13:12:26 UTC
I propose this bug as beta blocker as it violates the beta criterion: "The installer must be able to detect and install to hardware or firmware RAID storage devices."

Comment 8 Petr Schindler 2017-04-25 14:13:53 UTC
Similar problem has been detected:

I tried to reuse RAID1 disk with Fedora 26 installed.

addons:         com_redhat_kdump
cmdline:        /usr/libexec/system-python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
hashmarkername: anaconda
kernel:         4.11.0-0.rc6.git0.1.fc26.x86_64
other involved packages: python3-blivet-2.1.7-8.fc26.noarch, anaconda-gui-26.21.3-1.fc26.x86_64, python3-blockdev-2.6-3.fc26.x86_64
package:        anaconda-core-26.21.3-1.fc26.x86_64
product:        Fedora
reason:         gi.overrides.BlockDev.LVMError: Process reported exit code 1280:   WARNING: Device for PV TSsMvW-aiYf-nHYA-nlZL-ILpX-Md7F-wxF0de not found or rejected by a filter.
release:        Fedora release 26 (Twenty Six)
version:        26

Comment 9 Vratislav Podzimek 2017-04-25 14:34:29 UTC
(In reply to Petr Schindler from comment #8)
> Similar problem has been detected:
> 
> I tried to reuse RAID1 disk with Fedora 26 installed.
Was this also on a FW RAID machine?

Comment 10 Petr Schindler 2017-04-25 14:44:03 UTC
Yes. It was on the same machine as the first report.

Comment 11 Petr Schindler 2017-04-25 15:08:22 UTC
This bug seems to happen only when there is lvm on the raid.

I installed Fedora without lvm and I can reuse disk normally on next installation.

Comment 12 Vratislav Podzimek 2017-04-28 08:17:31 UTC
*** Bug 1445646 has been marked as a duplicate of this bug. ***

Comment 13 Geoffrey Marr 2017-05-01 18:30:21 UTC
Discussed during the 2017-05-01 blocker review meeting: [1]

The decision to classify this bug as an AcceptedBlocker was made as it violates the following blocker criteria:

"The installer must be able to detect and install to hardware or firmware RAID storage devices."

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2017-05-01/f26-blocker-review.2017-05-01-16.02.txt

Comment 14 David Lehman 2017-05-01 18:50:21 UTC
It would be useful to have storage.log and program.log attached.

Comment 15 Petr Schindler 2017-05-02 12:34:37 UTC
Created attachment 1275675 [details]
program.log

Comment 16 Petr Schindler 2017-05-02 12:35:10 UTC
Created attachment 1275676 [details]
storage.log

Comment 17 Vratislav Podzimek 2017-05-04 11:11:21 UTC
updates.img with fixes: http://vpodzime.fedorapeople.org/1445302_updates.img

Just please note that there's still a bug in lvmdbusd due to which later PvCreate fails.

Comment 18 Vratislav Podzimek 2017-05-04 11:51:34 UTC
https://github.com/rhinstaller/blivet/pull/583

Comment 19 Vratislav Podzimek 2017-05-05 07:06:15 UTC
(In reply to Vratislav Podzimek from comment #18)
> https://github.com/rhinstaller/blivet/pull/583

Merged.

Comment 20 Fedora Update System 2017-05-09 09:46:37 UTC
lvm2-2.02.168-5.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-f1874caad5

Comment 21 Marian Csontos 2017-05-09 09:51:57 UTC
Resetting status back to POST. Vrato, is there a lvm2 bug for the issue? I do not remember seeing one. I am fine with keeping track of it here. Are there any bodhi interactions which would be causing some problems for us?

Comment 22 Fedora Update System 2017-05-09 12:09:53 UTC
python-blivet-2.1.7-10.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-1c18277ac0

Comment 23 Fedora Update System 2017-05-12 02:11:25 UTC
lvm2-2.02.168-5.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-f1874caad5

Comment 24 Fedora Update System 2017-05-12 02:11:33 UTC
python-blivet-2.1.7-10.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-1c18277ac0

Comment 25 Vratislav Podzimek 2017-05-12 06:42:24 UTC
(In reply to Marian Csontos from comment #21)
> Resetting status back to POST. Vrato, is there a lvm2 bug for the issue? I
> do not remember seeing one. I am fine with keeping track of it here. Are
> there any bodhi interactions which would be causing some problems for us?

Sure: https://bugzilla.redhat.com/show_bug.cgi?id=1445654

Comment 26 Fedora Update System 2017-05-14 20:17:49 UTC
lvm2-2.02.168-5.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 27 Fedora Update System 2017-05-15 12:53:05 UTC
python-blivet-2.1.7-10.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 28 Adam Williamson 2017-05-15 23:15:25 UTC
Both updates have gone stable, but I haven't seen a clear verification that the issue is fixed; pschindl, can you please test with the next f26 compose? Thanks!

Comment 29 Petr Schindler 2017-05-22 17:38:19 UTC
I tested this with compose from 2017-05-17 and I can't reproduce this any more. This seems to be fixed.


Note You need to log in before you can comment on or make changes to this bug.