Bug 144540 - /etc/pam.d/system-auth not recreated automatically
Summary: /etc/pam.d/system-auth not recreated automatically
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: pam   
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-07 23:33 UTC by Samuli Kärkkäinen
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-10 08:54:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The new system-auth file. (820 bytes, text/plain)
2005-01-08 20:11 UTC, Samuli Kärkkäinen
no flags Details

Description Samuli Kärkkäinen 2005-01-07 23:33:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fi-FI; rv:1.7.5)
Gecko/20041108 Firefox/1.0

Description of problem:
Cron wasn't working for my non-root account "skarkkai", and in syslog
was appearing lines

crond[4420]: pam_succeed_if: requirement "uid < 100" not met by user
"skarkkai"

Invoking authconfig and clicking "Next" without making any changes
made some changes in /etc/pam.d/system-auth (I don't have the old one
readily accessible, but can dig it out if necessary), and cron started
working. Perhaps /etc/pam.d/system-auth should have been automatically
generated at some point where some pam settings related bug was fixed.

When I today ran authconfig, I had all the FC3 updates installed.

Comment 1 Tomas Mraz 2005-01-08 20:01:51 UTC
The problem is that we can't know if user didn't edit the system-auth
file by hand. If he did it would be really bad to rewrite it without
his manual intervention. Authconfig currently doesn't preserve most of
user changes of system-auth file.

However I agree sometimes it might be possible to use a script to
modify the system-auth file in the post install script of pam.

About your problem - the log message is probably irrelevant to the not
working cron because the authconfig only adds option to the
pam_succeed_if to not generate any logs. It must have been other bug.

Could you attach the new and old system-auth files?


Comment 2 Samuli Kärkkäinen 2005-01-08 20:11:03 UTC
Actually I, unfortunately, don't have the old system-auth file
anymore. I'll attach the new one anyway, though I don't expect it to
be of much help.


Comment 3 Samuli Kärkkäinen 2005-01-08 20:11:46 UTC
Created attachment 109522 [details]
The new system-auth file.

Comment 4 Tomas Mraz 2005-01-10 08:54:15 UTC
I don't see anything suspicious in your system-auth file, anything
that was fixed in recent time.
Note it could be even other files as /etc/nsswitch.conf.


Note You need to log in before you can comment on or make changes to this bug.