Bug 1445494 - selinux denials for rhsmcertd-worker
Summary: selinux denials for rhsmcertd-worker
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy
Version: 7.4
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
: 1447611 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-25 19:22 UTC by John Sefler
Modified: 2017-08-01 15:24 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 15:24:23 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1861 0 normal SHIPPED_LIVE selinux-policy bug fix update 2017-08-01 17:50:24 UTC

Description John Sefler 2017-04-25 19:22:41 UTC
Description of problem:
When rhsmcertd-worker triggers, several selinux denials are encountered.

Version-Release number of selected component (if applicable):
[root@jsefler-rhel7 ~]# rpm -q --whatprovides `which rhsmcertd`
subscription-manager-1.19.9-1.el7.x86_64
[root@jsefler-rhel7 ~]# rpm -q selinux-policy
selinux-policy-3.13.1-144.el7.noarch


How reproducible:


Steps to Reproduce:
[root@jsefler-rhel7 ~]# subscription-manager config --server.hostname=subscription.rhsm.stage.redhat.com

[root@jsefler-rhel7 ~]# subscription-manager register --auto-attach
Registering to: subscription.rhsm.stage.redhat.com:443/subscription
Username: qa@redhat.com
Password: 
The system has been registered with ID: 14938d2d-d2b0-45e7-b8e6-a890d098ab9a 

Installed Product Current Status:
Product Name: Red Hat Enterprise Linux Server
Status:       Subscribed

[root@jsefler-rhel7 ~]# subscription-manager config --rhsmcertd.splay=0

[root@jsefler-rhel7 ~]# service auditd restart
Stopping logging:                                          [  OK  ]
Redirecting start to /bin/systemctl start auditd.service

[root@jsefler-rhel7 ~]# setenforce 1

[root@jsefler-rhel7 ~]# restorecon -R /etc /run /var 

[root@jsefler-rhel7 ~]# START_DATE_TIME=`date "+%m/%d/%Y %T"`

[root@jsefler-rhel7 ~]# systemctl restart rhsmcertd.service

[root@jsefler-rhel7 ~]# sleep 120; sleep 10

[root@jsefler-rhel7 ~]# tail -f /var/log/rhsm/rhsmcertd.log
Tue Apr 25 15:17:29 2017 [INFO] Auto-attach interval: 1440.0 minutes [86400 seconds]
Tue Apr 25 15:17:29 2017 [INFO] Cert check interval: 240.0 minutes [14400 seconds]
Tue Apr 25 15:17:29 2017 [INFO] Waiting 2.0 minutes plus 0 splay seconds [120 seconds total] before performing first auto-attach.
Tue Apr 25 15:17:29 2017 [INFO] Waiting 2.0 minutes plus 0 splay seconds [120 seconds total] before performing first cert check.
Tue Apr 25 15:19:37 2017 [INFO] (Cert Check) Certificates updated.
Tue Apr 25 15:19:41 2017 [INFO] (Auto-attach) Certificates updated.

[root@jsefler-rhel7 ~]# ausearch -m AVC -m USER_AVC -m SELINUX_ERR -i -ts ${START_DATE_TIME}
----
type=SYSCALL msg=audit(04/25/2017 15:19:36.173:11713) : arch=x86_64 syscall=execve success=no exit=EACCES(Permission denied) a0=0x4541370 a1=0x24a48a0 a2=0x7ffc28951d88 a3=0x7ffc2894f130 items=0 ppid=25506 pid=25516 auid=unset uid=root gid=root euid=root suid=root fsuid=root egid=root sgid=root fsgid=root tty=(none) ses=unset comm=rhsmcertd-worke exe=/usr/bin/python2.7 subj=system_u:system_r:rhsmcertd_t:s0 key=(null) 
type=AVC msg=audit(04/25/2017 15:19:36.173:11713) : avc:  denied  { execute } for  pid=25516 comm=rhsmcertd-worke name=hostname dev="dm-0" ino=12817015 scontext=system_u:system_r:rhsmcertd_t:s0 tcontext=system_u:object_r:hostname_exec_t:s0 tclass=file 
----
type=SYSCALL msg=audit(04/25/2017 15:19:36.223:11714) : arch=x86_64 syscall=execve success=no exit=EACCES(Permission denied) a0=0x4522a50 a1=0x4519e90 a2=0x7ffc28951d88 a3=0x7ffc2894f2a0 items=0 ppid=25506 pid=25551 auid=unset uid=root gid=root euid=root suid=root fsuid=root egid=root sgid=root fsgid=root tty=(none) ses=unset comm=rhsmcertd-worke exe=/usr/bin/python2.7 subj=system_u:system_r:rhsmcertd_t:s0 key=(null) 
type=AVC msg=audit(04/25/2017 15:19:36.223:11714) : avc:  denied  { execute } for  pid=25551 comm=rhsmcertd-worke name=hostname dev="dm-0" ino=12817015 scontext=system_u:system_r:rhsmcertd_t:s0 tcontext=system_u:object_r:hostname_exec_t:s0 tclass=file 
----
type=SYSCALL msg=audit(04/25/2017 15:19:36.236:11715) : arch=x86_64 syscall=execve success=no exit=EACCES(Permission denied) a0=0x45fb800 a1=0x45f2c40 a2=0x7ffc28951d88 a3=0x7ffc2894ef20 items=0 ppid=25506 pid=25555 auid=unset uid=root gid=root euid=root suid=root fsuid=root egid=root sgid=root fsgid=root tty=(none) ses=unset comm=rhsmcertd-worke exe=/usr/bin/python2.7 subj=system_u:system_r:rhsmcertd_t:s0 key=(null) 
type=AVC msg=audit(04/25/2017 15:19:36.236:11715) : avc:  denied  { execute } for  pid=25555 comm=rhsmcertd-worke name=hostname dev="dm-0" ino=12817015 scontext=system_u:system_r:rhsmcertd_t:s0 tcontext=system_u:object_r:hostname_exec_t:s0 tclass=file 
----
type=SYSCALL msg=audit(04/25/2017 15:19:36.281:11716) : arch=x86_64 syscall=execve success=no exit=EACCES(Permission denied) a0=0x251ad20 a1=0x46043c0 a2=0x7ffc28951d88 a3=0x7ffc2894f090 items=0 ppid=25506 pid=25590 auid=unset uid=root gid=root euid=root suid=root fsuid=root egid=root sgid=root fsgid=root tty=(none) ses=unset comm=rhsmcertd-worke exe=/usr/bin/python2.7 subj=system_u:system_r:rhsmcertd_t:s0 key=(null) 
type=AVC msg=audit(04/25/2017 15:19:36.281:11716) : avc:  denied  { execute } for  pid=25590 comm=rhsmcertd-worke name=hostname dev="dm-0" ino=12817015 scontext=system_u:system_r:rhsmcertd_t:s0 tcontext=system_u:object_r:hostname_exec_t:s0 tclass=file 
[root@jsefler-rhel7 ~]# 



Actual results:
  above

Expected results:


Additional info:

Comment 2 Lukas Vrabec 2017-05-09 14:54:17 UTC
*** Bug 1447611 has been marked as a duplicate of this bug. ***

Comment 5 errata-xmlrpc 2017-08-01 15:24:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1861


Note You need to log in before you can comment on or make changes to this bug.